Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.13.4 (build 3149) - 03 October 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

*** Unofficial Users Map ***

Discussion and support for 3rd-party (non-Sandaysoft) tools for Cumulus
User avatar
beteljuice
Posts: 3280
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

*** Unofficial Users Map ***

Post by beteljuice »

Following discussion elsewhere I have created an Unofficial Cumulus Users Map.

You can use it as a standalone link or drop it in an <iframe> on your site. (NOT if you are https)

Create / Edit a marker: www.beteljuice.co.uk/CuMap/index.php?admin

Barebones url: www.beteljuice.co.uk/CuMap/index.php


You can 'enable' the home button on the auto-pilot, this also stops you being zapped and makes your marker RED :D
www.beteljuice.co.uk/CuMap/index.php?userID=dickie

You can choose to not display the user table by adding table=false
www.beteljuice.co.uk/CuMap/index.php?userID=dickie&table=false

You can initialize map to a country by adding country=???? ??? NB: MUST be exactly as seen in dropdown selector
www.beteljuice.co.uk/CuMap/index.php?country=Uruguay

... and there's more :shock:

in conjunction with ?userID=????? you can add &gotome - map initializes to world then zooms to you.
www.beteljuice.co.uk/CuMap/index.php?userID=dickie&gotome

but wait, why not use &country=??? ??? as well ;)
www.beteljuice.co.uk/CuMap/index.php?userID=dickie&gotome&country=United States

To use in an <iframe> on your site ... Edit ... Will NOT work if your site is 'secure' (https:// )

Code: Select all

<iframe src="http://www.beteljuice.co.uk/CuMap/index.php" style="width: 700px; height: 970px; border: none;"  allowfullscreen></iframe>
See frame in action here.

That's it .....
Last edited by beteljuice on Sun 03 Jan 2021 5:13 pm, edited 3 times in total.
Image
......................Imagine, what you will KNOW tomorrow !

AndyKF650
Posts: 106
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPi v4 Debian Buster Windows 10
Location: Jersey Channel Islands
Contact:

Re: *** Unofficial Users Map ***

Post by AndyKF650 »

Hi
This seems to be a very good idea, I have added some basic details to a map pin for me ie user name and location and it saved the info on the list. When I closed the page and reopened it whilst my user id showed on the list the map did not.

Do you have any thoughts on this problem?

Thanks

AndyK
Regards

AndyK

RayProudfoot
Posts: 2968
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: *** Unofficial Users Map ***

Post by RayProudfoot »

Same here, no map when I use this URL... http://www.beteljuice.co.uk/CuMap/index ... %20Kingdom
Cheers,
Ray, Cheshire.

Image

User avatar
mcrossley
Posts: 8906
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: *** Unofficial Users Map ***

Post by mcrossley »

It seems to be because 'AndyKF650' has entered his lat/long in an invalid format...
49.11.49, -2.2.2

The script is expecting decimal numbers. Some input validation is required.

AndyKF650
Posts: 106
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPi v4 Debian Buster Windows 10
Location: Jersey Channel Islands
Contact:

Re: *** Unofficial Users Map ***

Post by AndyKF650 »

Hi

Thanks for the assistance mark, I have updated my location to a decimal and all seems to look fine. Sorry for the inconvenience.

Regards

AndyK
Regards

AndyK

RayProudfoot
Posts: 2968
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: *** Unofficial Users Map ***

Post by RayProudfoot »

The map isn’t visible when viewed on a W10 laptop but is on my iPad. :?
Cheers,
Ray, Cheshire.

Image

AndyKF650
Posts: 106
Joined: Thu 20 Aug 2020 8:35 am
Weather Station: Davis VP2 Plus
Operating System: RPi v4 Debian Buster Windows 10
Location: Jersey Channel Islands
Contact:

Re: *** Unofficial Users Map ***

Post by AndyKF650 »

Hi Ray

I am looking at the map on a W10 pc with no problems, perhaps it is your pc browser settings causing the issue.

Regards

AndyK
Regards

AndyK

RayProudfoot
Posts: 2968
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: *** Unofficial Users Map ***

Post by RayProudfoot »

AndyKF650 wrote:
Tue 03 Nov 2020 10:05 am
Hi Ray

I am looking at the map on a W10 pc with no problems, perhaps it is your pc browser settings causing the issue.

Regards

AndyK
Yes, bloody computers! Do nothing and now it shows! :lol:
Cheers,
Ray, Cheshire.

Image

User avatar
beteljuice
Posts: 3280
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: *** Unofficial Users Map ***

Post by beteljuice »

mark wrote:It seems to be because 'AndyKF650' has entered his lat/long in an invalid format...
49.11.49, -2.2.2

The script is expecting decimal numbers. Some input validation is required.
In defence of the beteljuice it does say (decimal) next to the input field, and the "Tip" to find / fine tune the location, points you to values that are decimal notation, plus the map code itself validates and advises of lat / lon ranges
..... but apparently doesn't check if they are numeric in the first place :bash:

numeric check at Point Of Entry introduced ;)
Ray wrote:Yes, bloody computers! Do nothing and now it shows!
I am sooooo pleased about that. I thought we were going to have an "Edge" problem - In which case I would have pulled the plug :x
Image
......................Imagine, what you will KNOW tomorrow !

RayProudfoot
Posts: 2968
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: *** Unofficial Users Map ***

Post by RayProudfoot »

beteljuice wrote:
Tue 03 Nov 2020 10:59 pm
Ray wrote:Yes, bloody computers! Do nothing and now it shows!
I am sooooo pleased about that. I thought we were going to have an "Edge" problem - In which case I would have pulled the plug :x
Don’t use Edge. Still with Firefox. :D Any chance the link could appear on the main forum page at the top like in the olden days?
Cheers,
Ray, Cheshire.

Image

User avatar
beteljuice
Posts: 3280
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: *** Unofficial Users Map ***

Post by beteljuice »

Ray wrote:Any chance the link could appear on the main forum page at the top like in the olden days?
That needs must be an executive decision - but I would recommend waiting to see what the "take-up" is, and if any serious bugs come to light,
Image
......................Imagine, what you will KNOW tomorrow !

User avatar
PaulMy
Posts: 2751
Joined: Sun 28 Sep 2008 11:54 pm
Weather Station: Davis VP2+ Cumulus1 / CummulusMX
Operating System: Windows8 / Windows10
Location: Komoka, ON Canada
Contact:

Re: *** Unofficial Users Map ***

Post by PaulMy »

I am sooooo pleased about that. I thought we were going to have an "Edge" problem - In which case I would have pulled the plug :x
Don’t use Edge. Still with Firefox. :D
I use Edge and it works well.

Enjoy,
Paul

User avatar
billy
Posts: 175
Joined: Mon 30 Nov 2015 10:54 am
Weather Station: Davis VP2+
Operating System: RPi buster
Location: Gooseberry Hill, Western Australia

Re: *** Unofficial Users Map ***

Post by billy »

Many thanks beteljuice - I'm on the map - very nicely done :clap: :clap: :clap:

RayProudfoot
Posts: 2968
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: *** Unofficial Users Map ***

Post by RayProudfoot »

beteljuice wrote:
Tue 03 Nov 2020 11:51 pm
Ray wrote:Any chance the link could appear on the main forum page at the top like in the olden days?
That needs must be an executive decision - but I would recommend waiting to see what the "take-up" is, and if any serious bugs come to light,
Makes sense. ;)
Cheers,
Ray, Cheshire.

Image

User avatar
beteljuice
Posts: 3280
Joined: Tue 09 Dec 2008 1:37 pm
Weather Station: None !
Operating System: W10 - Threadripper 16core, etc
Location: Dudley, West Midlands, UK

Re: *** Unofficial Users Map ***

Post by beteljuice »

Ahrghh :x - big problem found when embedding (Thank you griffo)

my response to his problem ..
Ahhh ... modern times / browsers ...

Took me a while to twig what was going on.

Your site is 'secure' (https://), mine isn't - <iframe> 'insecure' content is being blocked !
Any ideas ??? :?
Image
......................Imagine, what you will KNOW tomorrow !

Post Reply