Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

Help with Toolbox

Discussion and support for 3rd-party (non-Sandaysoft) tools for Cumulus
cb6888
Posts: 12
Joined: Thu 30 Jan 2014 7:15 am
Weather Station: Ambient Weather WS-2040
Operating System: Windows Vista SP2
Location: Brentwood, TN

Re: Help with Toolbox

Post by cb6888 » Sun 02 Feb 2014 2:09 pm

Yes, sorry for the confusion. While far from a computer expert, I can usually figure things out. For some reason, this just isn't "clicking." But, I think I'm begining to wrap my head around it. So, in Toolbox, in the "Current" value block, I should have the value from the last time the web tags were updated, whether or not that value is in excess of the rule. Am I correct?

After midnight last night, my New Record light in Cumulus itself began flashing again. No email, and the "Current" value was 0. So, I am guessing that things are not updating for some reason.

I sincerely appreciate your patience!

water01
Posts: 1486
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Help with Toolbox

Post by water01 » Sun 02 Feb 2014 4:11 pm

Yes you are correct i.e. in that picture I sent you my test was 0.0 and the current value below it was 6.4, therefore the rule would fail. 6.4 came from the last updated cumuluswebtags.txt.

If you are not seeing values below your test value in Current, then there is mismatch between where Cumulus is processing cumuluswebtags.txt and where Toolbox thinks it is and therefore Toolbox does not see the values against which to test.

cb6888
Posts: 12
Joined: Thu 30 Jan 2014 7:15 am
Weather Station: Ambient Weather WS-2040
Operating System: Windows Vista SP2
Location: Brentwood, TN

Re: Help with Toolbox

Post by cb6888 » Sun 02 Feb 2014 11:43 pm

But I've confirmed within both Cumulus and Toolbox that both programs point to the same file. Could I have neglected to enable something in Cumulus? Is FTP required, even though I'm just going to be using email notifications?

water01
Posts: 1486
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Help with Toolbox

Post by water01 » Mon 03 Feb 2014 12:24 am

You do not have to FTP it but you have to have a tick in the process box and a remote file name (that could be C:\Temp) so that the file is processed by Cumulus

So in one of the Configuration / Internet / File Tab lines within Cumulus you should have something like

Local filename = C:\Cumulus\data\cumuluswebtags.txt
Remote filename = C:\Temp\cumuluswebtags.txt
Process = Yes (i.e. tick the box)
Realtime = No (i.e no tick in the box)
FTP = No (i.e. no tick the box)

cb6888
Posts: 12
Joined: Thu 30 Jan 2014 7:15 am
Weather Station: Ambient Weather WS-2040
Operating System: Windows Vista SP2
Location: Brentwood, TN

Re: Help with Toolbox

Post by cb6888 » Mon 03 Feb 2014 3:38 am

Eureka!

Inside Cumulus/Configuration/Internet/Files, I had cumuluswebtags.php, instead of cumuluswebtags.txt as the remote filename. Once I made the charge, it started clicking right along.

Throughout this process, I suspected it was something embarassingly simple that was the problem. Thank you so much for walking me through it, I greatly appreciate it!

water01
Posts: 1486
Joined: Sat 13 Aug 2011 9:33 am
Weather Station: WH1081
Operating System: Windows 7 64bit HP SP1
Location: Somewhere in the USA
Contact:

Re: Help with Toolbox

Post by water01 » Mon 03 Feb 2014 9:19 am

Great, no problem, been there done that, got the t-shirt!!

Post Reply