Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.3.0 build 3063 - 10 January 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Cumulusutils

    Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

    Moderator: daj

    User avatar
    PaulMy
    Posts: 2031
    Joined: Sun 28 Sep 2008 11:54 pm
    Weather Station: Davis Vantage Pro 2+ w/Envoy USB
    Operating System: Windows-8
    Location: Komoka, ON Canada
    Contact:

    Re: Cumulusutils

    Post by PaulMy » Mon 16 Sep 2019 8:23 pm

    Dang@#$%^ had another computer shutdown trying to run cmd :bash:
    11 programs to restart on the weather computer :groan: but everything back working, I think.
    Searching for guidance and noticed in the cumulusutils.exe a comment This program cannot be run in DOS mode.

    Anyway, while much of this is over my head I am persistent :clap: and now got a pwsFWI.txt top10Table.txt and top10TableStyle.txt along with a cumulusutils.log that has 131,873 lines and is 9,235 kb from dayfile.txt going back to 2008 ;)

    You'll likely now say - enjoy!

    Enjoy,
    Paul

    Phil23
    Posts: 377
    Joined: Sat 16 Jul 2016 11:59 pm
    Weather Station: Davis Vantage Pro2 Plus
    Operating System: Win7 Pro
    Location: Australia

    Re: Cumulusutils

    Post by Phil23 » Mon 16 Sep 2019 8:49 pm

    HansR wrote:
    Mon 16 Sep 2019 9:43 am
    Added system info in version 0.6.0

    Unfortunately this is for Linux/Unix only.
    Don't know what your output contains as I haven't run it on the rPi yet.

    But in Windows, systeminfo at a command prompt returns the following.
    Is this something you can call & filter the data you want as required.

    Code: Select all

    C:\Users\Phil>systeminfo
    
    Host Name:                 PHILS-TECRAI7
    OS Name:                   Microsoft Windows 10 Pro
    OS Version:                10.0.18362 N/A Build 18362
    OS Manufacturer:           Microsoft Corporation
    OS Configuration:          Standalone Workstation
    OS Build Type:             Multiprocessor Free
    Registered Owner:          N/A
    Registered Organization:   Toshiba
    Product ID:                00330-50519-57474-AAOEM
    Original Install Date:     29/07/2019, 11:26:09 AM
    System Boot Time:          11/09/2019, 9:55:07 PM
    System Manufacturer:       TOSHIBA
    System Model:              TECRA A50-C
    System Type:               x64-based PC
    Processor(s):              1 Processor(s) Installed.
                               [01]: Intel64 Family 6 Model 78 Stepping 3 GenuineIntel ~2600 Mhz
    BIOS Version:              TOSHIBA Version 8.40  , 20/11/2018
    Windows Directory:         C:\WINDOWS
    System Directory:          C:\WINDOWS\system32
    Boot Device:               \Device\HarddiskVolume1
    System Locale:             en-au;English (Australia)
    Input Locale:              en-us;English (United States)
    Time Zone:                 (UTC+10:00) Canberra, Melbourne, Sydney
    Total Physical Memory:     16,316 MB
    Available Physical Memory: 7,811 MB
    Virtual Memory: Max Size:  18,748 MB
    Virtual Memory: Available: 7,038 MB
    Virtual Memory: In Use:    11,710 MB
    Page File Location(s):     C:\pagefile.sys
    Domain:                    WORKGROUP
    Logon Server:              \\PHILS-TECRAI7
    Hotfix(s):                 7 Hotfix(s) Installed.
                               [01]: KB4514359
                               [02]: KB4503308
                               [03]: KB4508433
                               [04]: KB4509096
                               [05]: KB4515383
                               [06]: KB4516115
                               [07]: KB4515384
    Network Card(s):           4 NIC(s) Installed.
                               [01]: DrayTek Virtual PPP Adapter
                                     Connection Name: Local Area Connection
                                     DHCP Enabled:    No
                                     IP address(es)
                               [02]: Intel(R) Ethernet Connection I219-V
                                     Connection Name: Ethernet
                                     Status:          Media disconnected
                               [03]: Intel(R) Dual Band Wireless-AC 8260
                                     Connection Name: Wi-Fi
                                     DHCP Enabled:    Yes
                                     DHCP Server:     192.168.59.10
                                     IP address(es)
                                     [01]: 192.168.59.21
                               [04]: Bluetooth Device (Personal Area Network)
                                     Connection Name: Bluetooth Network Connection
                                     Status:          Media disconnected
    Hyper-V Requirements:      VM Monitor Mode Extensions: Yes
                               Virtualization Enabled In Firmware: Yes
                               Second Level Address Translation: Yes
                               Data Execution Prevention Available: Yes
    
    C:\Users\Phil>
    
    
    Image

    User avatar
    HansR
    Posts: 506
    Joined: Sat 20 Oct 2012 6:53 am
    Weather Station: Davis Vantage Pro 2+
    Operating System: Raspbian GNU/Linux 10 (Buster)
    Location: Wagenborgen (NL)
    Contact:

    Re: Cumulusutils

    Post by HansR » Tue 17 Sep 2019 4:25 am

    @PaulMy: I actually don't think your crash results from my program. If you do not see a stack dump on the console and your output is complete (check the log-file, is should end with "CumulusUtils : Exiting Main"), the cause must be somewhere else.

    @Phil23: Thank you, this will bring me a lot further! Not sure though this will have the same output on Windows 7 and 8. If anybody has those examples, that would be nice.

    Should be able to do this with a c# library but I do not seem to get access to it. Somebody has info on howto?
    Otherwise I am stuck with system calls. :(
    https://meteo-wagenborgen.nl / Cumulus (3.3.0 b3063)
    Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
    Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
    Mono JIT compiler version 6.8.0.96 (tarball Wed Jan 15 10:23:49 UTC 2020)

    Phil23
    Posts: 377
    Joined: Sat 16 Jul 2016 11:59 pm
    Weather Station: Davis Vantage Pro2 Plus
    Operating System: Win7 Pro
    Location: Australia

    Re: Cumulusutils

    Post by Phil23 » Tue 17 Sep 2019 9:51 am

    Systeminfo output looks basically the same in Win7 & Win8.

    Have XP, 7, 8, 10 & Server 2003, 2008R1, 2008R2 & 2012 running here so can compare the lot in the next day or so.
    Image

    User avatar
    HansR
    Posts: 506
    Joined: Sat 20 Oct 2012 6:53 am
    Weather Station: Davis Vantage Pro 2+
    Operating System: Raspbian GNU/Linux 10 (Buster)
    Location: Wagenborgen (NL)
    Contact:

    Re: Cumulusutils

    Post by HansR » Tue 17 Sep 2019 10:02 am

    Thanks Phil, if you can send me those outputs by mail. It is required for the filtering. If the output differs, I need to make a distinction between versions, otherwise I can do the same for all versions (which makes life easier :) ).
    https://meteo-wagenborgen.nl / Cumulus (3.3.0 b3063)
    Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
    Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
    Mono JIT compiler version 6.8.0.96 (tarball Wed Jan 15 10:23:49 UTC 2020)

    User avatar
    HansR
    Posts: 506
    Joined: Sat 20 Oct 2012 6:53 am
    Weather Station: Davis Vantage Pro 2+
    Operating System: Raspbian GNU/Linux 10 (Buster)
    Location: Wagenborgen (NL)
    Contact:

    Re: Cumulusutils

    Post by HansR » Tue 17 Sep 2019 1:34 pm

    Version 0.6.5 is ready. The System Info should now be OK for Unux and Windows. Only tested on Linux and Windows 10. So be prepared.
    Preparations for ini-file are done and the Cumulus.ini can be read - of course not written to! - providing a wealth of information.
    https://meteo-wagenborgen.nl / Cumulus (3.3.0 b3063)
    Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
    Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
    Mono JIT compiler version 6.8.0.96 (tarball Wed Jan 15 10:23:49 UTC 2020)

    User avatar
    PaulMy
    Posts: 2031
    Joined: Sun 28 Sep 2008 11:54 pm
    Weather Station: Davis Vantage Pro 2+ w/Envoy USB
    Operating System: Windows-8
    Location: Komoka, ON Canada
    Contact:

    Re: Cumulusutils

    Post by PaulMy » Tue 17 Sep 2019 2:11 pm

    Hi Hans, and sorry I wasn't clear to indicate that my latest Windows shut down was certainly not cumulusutils related, as it was a CMD issue. And likely the earlier time as well.

    I've now got the hang of it and have a test page.

    Thank you for your work on this, and your patience.

    Enjoy,
    Paul

    User avatar
    PaulMy
    Posts: 2031
    Joined: Sun 28 Sep 2008 11:54 pm
    Weather Station: Davis Vantage Pro 2+ w/Envoy USB
    Operating System: Windows-8
    Location: Komoka, ON Canada
    Contact:

    Re: Cumulusutils

    Post by PaulMy » Tue 17 Sep 2019 3:16 pm

    Hi Hans,
    v051 works on both Cumulus1 and CumulusMX.

    I also tried v065 and it does not work on either Cumulus1 or CumulusMX, see attached screen shot

    Regards,
    Paul
    Last edited by PaulMy on Thu 19 Sep 2019 1:00 pm, edited 1 time in total.

    User avatar
    HansR
    Posts: 506
    Joined: Sat 20 Oct 2012 6:53 am
    Weather Station: Davis Vantage Pro 2+
    Operating System: Raspbian GNU/Linux 10 (Buster)
    Location: Wagenborgen (NL)
    Contact:

    Re: Cumulusutils

    Post by HansR » Tue 17 Sep 2019 3:48 pm

    That is seriously strange. 0.6.5 runs with me on both my Windows 10 and on my rPi machine.
    It is more important that you mention the machine and OS than the fact that it runs with Cumulus 1.9.4 and MX because basically, it can run on any machine with or without Cumulus, as long as there is dayfile.txt to access, So I think this is an OS/.NET problem. Do you have the versions for it? I assume this to be Windows 8 and that it is connected to the internet. Are updates automatic installed? Hmmm... still enjoying yourself :|
    https://meteo-wagenborgen.nl / Cumulus (3.3.0 b3063)
    Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
    Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
    Mono JIT compiler version 6.8.0.96 (tarball Wed Jan 15 10:23:49 UTC 2020)

    User avatar
    PaulMy
    Posts: 2031
    Joined: Sun 28 Sep 2008 11:54 pm
    Weather Station: Davis Vantage Pro 2+ w/Envoy USB
    Operating System: Windows-8
    Location: Komoka, ON Canada
    Contact:

    Re: Cumulusutils

    Post by PaulMy » Tue 17 Sep 2019 4:24 pm

    Hi Hans,
    Of course, it is dayfile.txt that is used and not Cumulus program.

    It is my old Acer AX3470-EB358 Windows8 weather computer and there are no automatic updates that I am aware off. And a long time since I updated anything related to Windows other than Windows Defender. There are 40 updates available 705.4 MB ready to install, but I am afraid to :oops:

    Yes still enjoying, but hair is whiter and less of it!
    Paul

    User avatar
    HansR
    Posts: 506
    Joined: Sat 20 Oct 2012 6:53 am
    Weather Station: Davis Vantage Pro 2+
    Operating System: Raspbian GNU/Linux 10 (Buster)
    Location: Wagenborgen (NL)
    Contact:

    Re: Cumulusutils

    Post by HansR » Tue 17 Sep 2019 4:41 pm

    I understand the worry for upgrading. However, in that case I don't think it is worth spending much energy on cumulusutils on that machine. Otherwise the hair may become a whiter shade of pale ;)
    https://meteo-wagenborgen.nl / Cumulus (3.3.0 b3063)
    Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
    Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
    Mono JIT compiler version 6.8.0.96 (tarball Wed Jan 15 10:23:49 UTC 2020)

    User avatar
    PaulMy
    Posts: 2031
    Joined: Sun 28 Sep 2008 11:54 pm
    Weather Station: Davis Vantage Pro 2+ w/Envoy USB
    Operating System: Windows-8
    Location: Komoka, ON Canada
    Contact:

    Re: Cumulusutils

    Post by PaulMy » Tue 17 Sep 2019 7:04 pm

    Hi Hans,
    Can the program be run automatically by Cumulus through the Internet Settings External programs - Daily program?

    Enjoy,
    Paul

    User avatar
    HansR
    Posts: 506
    Joined: Sat 20 Oct 2012 6:53 am
    Weather Station: Davis Vantage Pro 2+
    Operating System: Raspbian GNU/Linux 10 (Buster)
    Location: Wagenborgen (NL)
    Contact:

    Re: Cumulusutils

    Post by HansR » Tue 17 Sep 2019 8:36 pm

    Hi Paul,
    Yes you can. That is actually how I run it. If you run more programs at that time, maybe you better create a batch file with all commands in it, to sequentially start all of them at that time and start that batch file through Cumulus. Hope it works. Are you passed the crashes now?
    https://meteo-wagenborgen.nl / Cumulus (3.3.0 b3063)
    Davis Vantage Pro 2+ / Raspberry Pi 3 Model B Plus Rev 1.3
    Raspbian GNU/Linux 10 (buster) / Linux 4.19.75-v7+ armv7l
    Mono JIT compiler version 6.8.0.96 (tarball Wed Jan 15 10:23:49 UTC 2020)

    Phil23
    Posts: 377
    Joined: Sat 16 Jul 2016 11:59 pm
    Weather Station: Davis Vantage Pro2 Plus
    Operating System: Win7 Pro
    Location: Australia

    Re: Cumulusutils

    Post by Phil23 » Tue 17 Sep 2019 8:52 pm

    HansR wrote:
    Tue 17 Sep 2019 10:02 am
    Thanks Phil, if you can send me those outputs by mail.
    Will do, but need to get a chance to drop a Cumulus folder with data on each machine, or maybe try just running from a USB drive.

    In any case just tried on my Win8 weather PC & output looks fine.

    Code: Select all

    <pre>
    Cumulus uptime: <#ProgramUpTime>
    Weather station: Davis Vantage Pro2
    
    Total number of data packets received: <#DavisTotalPacketsReceived>
    Number of missed data packets: <#DavisTotalPacketsMissed>
    Longest streak of consecutive packets received: <#DavisMaxInARow>
    Number of packets received with CRC errors: <#DavisNumCRCerrors>
    The console firmware version: <#DavisFirmwareVersion>
    Number of times the console resynchronised with the transmitter: <#DavisNumberOfResynchs>
    The console battery condition in volts: <#battery> V
    The transmitter battery condition: <#txbattery>
    
    Windows
    
    OS Name:                   Microsoft Windows 8.1
    OS Version:                6.3.9600 N/A Build 9600
    OS Manufacturer:           Microsoft Corporation
    OS Configuration:          Standalone Workstation
    OS Build Type:             Multiprocessor Free
    Original Install Date:     27/09/2016, 4:45:09 PM
    System Boot Time:          26/07/2019, 6:32:38 AM
    System Manufacturer:       Hewlett-Packard
    System Model:              HP Pavilion g6 Notebook PC
    System Type:               x64-based PC
    Processor(s):              1 Processor(s) Installed.
                               [01]: AMD64 Family 21 Model 16 Stepping 1 AuthenticAMD ~2700 Mhz
    BIOS Version:              Insyde F.26, 21/02/2013
    Windows Directory:         C:\Windows
    System Directory:          C:\Windows\system32
    Boot Device:               \Device\HarddiskVolume1
    System Locale:             en-au;English (Australia)
    Input Locale:              en-us;English (United States)
    Time Zone:                 (UTC+10:00) Canberra, Melbourne, Sydney
    Total Physical Memory:     3,560 MB
    Available Physical Memory: 1,827 MB
    Virtual Memory: Max Size:  4,200 MB
    Virtual Memory: Available: 1,955 MB
    Virtual Memory: In Use:    2,245 MB
    </pre>
    <p><small>CumulusUtils Version 0.6.5 / by Hans Rottier - generated at 18/09/2019 06:43</small></p>
    
    Image

    User avatar
    PaulMy
    Posts: 2031
    Joined: Sun 28 Sep 2008 11:54 pm
    Weather Station: Davis Vantage Pro 2+ w/Envoy USB
    Operating System: Windows-8
    Location: Komoka, ON Canada
    Contact:

    Re: Cumulusutils

    Post by PaulMy » Tue 17 Sep 2019 10:18 pm

    Thanks Hans,
    FYI I've tried the external program in both Cumulus1 and CumulusMX.

    I got success in CumulusMX.

    Cumulus1 debug is showing:
    9408.4250 : 17/09/2019 5:45:03 PM Executing program: c:\added_programs\Cumulus\cumulusutils.exe - Params: -day
    and no errors reported but the files are not showing in the c:\added_programs\Cumulus folder.

    Using the run c:\added_programs\Cumulus\cumulusutils.exe -day then the files are added in the c:\added_programs\Cumulus folder.

    Yes, feel much more comfortable, and also cautious what I enter!

    Enjoy,
    Paul

    Post Reply