Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

PHP Link not being updated - Help please

Other discussion about creating web sites for Cumulus that doesn't have a specific subforum

Moderator: daj

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Mon 20 Mar 2017 10:24 pm

Thanks! :clap:
Cheers,
Ray, Cheshire.

Image

User avatar
ConligWX
Posts: 734
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: PHP Link not being updated - Help please

Post by ConligWX » Mon 20 Mar 2017 10:33 pm

steve wrote:No, didn't cost anything.
Yep, I told you guys it was free:) the only issue users may face is they must ensure all links within their site are pointing to https url content.

https://support.google.com/chrome/answe ... cator&rd=1
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Mon 20 Mar 2017 10:44 pm

Thanks Simon. There are no links on my website to the banner. I use it exclusively in a couple of signature blocks in forums. I haven't had to alter my sig for this place as it's not an https site... yet. ;)
Cheers,
Ray, Cheshire.

Image

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Mon 20 Mar 2017 11:07 pm

Since I updated my sig and saved it 40 mins ago it is still showing the same time as when it was saved. Why isn't it updating?

The code I used is the same as my sig here with the exception of the extra 's'. I've removed opening and closing brackets to show the actual code.

url=https://www.cheadlehulmeweather.co.uk/][imghttps://www.cheadlehulmeweather.co.uk/banner.php?source=view[/img[/url

Stumped. :roll:
Cheers,
Ray, Cheshire.

Image

User avatar
ConligWX
Posts: 734
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: PHP Link not being updated - Help please

Post by ConligWX » Mon 20 Mar 2017 11:28 pm

RayProudfoot wrote:Since I updated my sig and saved it 40 mins ago it is still showing the same time as when it was saved. Why isn't it updating?

The code I used is the same as my sig here with the exception of the extra 's'. I've removed opening and closing brackets to show the actual code.

url=https://www.cheadlehulmeweather.co.uk/][imghttps://www.cheadlehulmeweather.co.uk/banner.php?source=view[/img[/url

Stumped. :roll:

mine work like so:

Code: Select all

[url=https://www.conligwx.org/][img]https://www.conligwx.org/banner.php[/img][/url]
like so:

Image

Image
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Mon 20 Mar 2017 11:48 pm

Thanks. Do you think the source=view might be the cause of the lack of updates?
Cheers,
Ray, Cheshire.

Image

User avatar
saratogaWX
Posts: 912
Joined: Wed 06 May 2009 5:02 am
Weather Station: Davis Vantage Pro Plus
Operating System: Windows 10 Professional
Location: Saratoga, CA, USA
Contact:

Re: PHP Link not being updated - Help please

Post by saratogaWX » Tue 21 Mar 2017 3:07 am

Yes, the "?source=view" is likely the cause. On my scripts, that causes a display of the source code for the PHP script.
For your banner, you want the banner.php to just run (and send back an image, not the PHP source code).

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Tue 21 Mar 2017 9:17 am

Thanks saratoga but removing that part made no difference. A tech guy there suggested it's down to their caching so they will see if they can change it for non-secure sites.

All this has happened because they've moved to a https site. It's primarily a discussion place for flight simmers so why they feel the need for such high levels of security I don't really know.

My weather site has no known risks. Yes, it runs Adobe Flash but only for world times and the phase of the moon. It's never been hacked. I despair.
Cheers,
Ray, Cheshire.

Image

User avatar
ConligWX
Posts: 734
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: PHP Link not being updated - Help please

Post by ConligWX » Tue 21 Mar 2017 10:14 am

If their webserver is caching data, then your banner would not update correctly in realtime. Is your web browser caching the banner as well?

I ask as my webcam image which is on my Webserver was being cached by my web browser when using the Weather Station Template by Brian Underwood.

I ended up adding some html code to the cam.php so web browser did not cache that information either.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Tue 21 Mar 2017 10:25 am

Pretty sure my browser is not caching data because when I visit this place the banner shows the current time. Proof enough?
Cheers,
Ray, Cheshire.

Image

User avatar
ConligWX
Posts: 734
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: Debian 9.5 Stretch
Location: Bangor, NI
Contact:

Re: PHP Link not being updated - Help please

Post by ConligWX » Tue 21 Mar 2017 11:03 am

RayProudfoot wrote:Pretty sure my browser is not caching data because when I visit this place the banner shows the current time. Proof enough?
so you can see part of your banner - the time, but no other info from banner is shown on the other forum??????

Each website will have different methods of showing web content. Apache, nginx, IIS, and various Caching methods with Zend Opcache etc. what may work on one, may not work on another.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Tue 21 Mar 2017 11:21 am

Toxic17 wrote:
RayProudfoot wrote:Pretty sure my browser is not caching data because when I visit this place the banner shows the current time. Proof enough?
so you can see part of your banner - the time, but no other info from banner is shown on the other forum??????

Each website will have different methods of showing web content. Apache, nginx, IIS, and various Caching methods with Zend Opcache etc. what may work on one, may not work on another.
No, I can see the whole banner but the time is frozen. It needs their caching to change so it's refreshed when the topic is read by users. Just like here. I don't think there's anything I can do now except wait for them to change the caching.
Cheers,
Ray, Cheshire.

Image

User avatar
duke
Posts: 840
Joined: Sun 03 Jul 2011 6:23 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 - 64 bit
Location: Eastleigh, Hampshire, UK
Contact:

Re: PHP Link not being updated - Help please

Post by duke » Tue 21 Mar 2017 9:25 pm

Your opening 'img' tag is also missing a ']' assuming you cut'n'paste correctly ;)
Duke

Nightingale Weather
Eastleigh, Hampshire, UK
------------------------------------------------------
Validate your pages - often!

RayProudfoot
Posts: 2632
Joined: Wed 06 May 2009 6:29 pm
Weather Station: Davis VP2 with Daytime FARS
Operating System: Windows XP SP3
Location: Cheadle Hulme, Cheshire, England
Contact:

Re: PHP Link not being updated - Help please

Post by RayProudfoot » Tue 21 Mar 2017 10:50 pm

duke wrote:Your opening 'img' tag is also missing a ']' assuming you cut'n'paste correctly ;)
That was deliberate and just to show here. Using the full text just showed the graphic and not the code.
Cheers,
Ray, Cheshire.

Image

Post Reply