Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.4.0 (build 3064) - 19 February 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Download from Station stuck

    Discussion specific to Fine Offset and similar rebadged weather stations
    Post Reply
    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Download from Station stuck

    Post by CumuFin » Thu 11 Dec 2008 6:45 pm

    After using this marvellous piece of software for a week i have encountered this error:

    I am stuck with the download dialog. After closing Cumulus I have the error report below.
    I have erased all data from the WS1081 device.
    Can you help?

    version : 1.8.4.589
    compiled with : Delphi 2006/07
    madExcept version : 3.0h
    callstack crc : $688f1aac, $9bffdddc, $bbcdf4af
    exception number : 1
    exception class : EAccessViolation
    exception message : Access violation at address 688F1AAC. Read of address 688F1AAC.

    thread $cf4 (TJvHidDeviceReadThread):
    688f1aac +00 ???
    0065cac0 +24 cumulus.exe JvHidControllerClass TJvHidDevice.GetCaps
    0065bf59 +1d cumulus.exe JvHidControllerClass TJvHidDeviceReadThread.Execute
    00450bbf +2b cumulus.exe madExcept HookedTThreadExecute
    00477414 +34 cumulus.exe Classes ThreadProc
    0040592c +28 cumulus.exe System 48 +0 ThreadWrapper
    00450aa1 +0d cumulus.exe madExcept CallThreadProcSafe
    00450b0b +37 cumulus.exe madExcept ThreadExceptFrame
    >> created by main thread ($eac) at:
    0065be95 +21 cumulus.exe JvHidControllerClass TJvHidDeviceReadThread.CtlCreate

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Download from Station stuck

    Post by steve » Thu 11 Dec 2008 7:10 pm

    Firstly, I think this error occurred as a result of closing it down while it was reading from the station.

    How long was it 'stuck'? You say you erased the data - was this before it got stuck? I assume it keeps getting stuck every time you run it now?

    Could you send me the contents of the Diags folder, please.

    Steve

    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Re: Download from Station stuck

    Post by CumuFin » Thu 11 Dec 2008 10:19 pm

    Hi Steve

    you are right it was stuck every time i started it. However, I have now managed to erase the data from the station via hardware reset and re-installed version 1.84; and I am happy to report everything works now.
    You reckon you can include a data reset in cumulus like the function in Easy Weather?
    Again thanks for the help and keep up the very good work!

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Download from Station stuck

    Post by steve » Thu 11 Dec 2008 11:17 pm

    I'm afraid I can't do any 'control' type functions as I don't have the necessary information, and Fine Offset don't seem to want to give it to me.

    Steve

    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Re: Download from Station stuck

    Post by CumuFin » Sun 14 Dec 2008 8:32 pm

    a shame that control functions and their programming code is not made available. surely it would make a good weather station model even more desirable. Pity as I shall have to keep easyweather for setting alarms etc.

    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Re: Download from Station stuck

    Post by CumuFin » Mon 29 Dec 2008 10:37 am

    bizarly enough the weather station reset itself (including all data). As a result cumulus cant handle the download of data and is stuck again. See error

    callstack crc : $688f1aac, $9bffdddc, $a02b5ba2
    count : 2
    exception number : 1
    exception class : EAccessViolation
    exception message : Access violation at address 688F1AAC. Read of address 688F1AAC.

    It seems to expect certain data but cannot find it. Would this be a date/time stamp?


    diag file content:

    2008-12-29 10:25:55 : Cumulus 1.8.4 Build 589 startup

    =============================== OS version info =================================
    Platform : Windows NT, Windows 2000, Windows XP, or Windows Server 2003 family.
    OS Name : Windows XP (Service Pack 3)
    (Major Version[ 5 ] Minor Version[ 1 ] Build Number[ 2600 ] Platform ID[ 2 ])
    ===================================================================================

    2008-12-29 10:25:55 : Showing main form
    2008-12-29 10:25:55 : Read today file: Date = 29/12/2008, LastUpdateTime = 29/12/2008 10:05:31
    2008-12-29 10:25:55 : Todayfileraindaystart = 51.5999984741211
    2008-12-29 10:25:55 : Todayfile is for today
    2008-12-29 10:25:55 : ReadTodayfile: set notraininit false
    2008-12-29 10:25:55 : Read yesterday file: Date = 29/12/2008
    2008-12-29 10:25:55 : Yesterday file is valid
    2008-12-29 10:25:55 : Rainthismonth from dayfile.txt: 20.3999977111816
    2008-12-29 10:25:55 : EWUSB Form Create
    2008-12-29 10:25:55 : EWUSB: HidControl Arrival
    2008-12-29 10:25:55 : EWUSB: HidControl DeviceChange
    2008-12-29 10:25:57 : EWUSB: Initialising EW USB
    2008-12-29 10:25:57 : USB device, VID = 1941 PID = 8021
    2008-12-29 10:25:57 : EWUSB: Found Fine Offset station
    2008-12-29 10:25:57 : EWUSB: Get history data
    2008-12-29 10:25:57 : Request EW data block, addr = 000000
    2008-12-29 10:25:57 : EWUSB: EW startup data line 01 55 AA A0 20 A1 04 A0 20
    2008-12-29 10:25:57 : EWUSB: EW startup data line 02 55 AA FF FF FF FF FF FF
    2008-12-29 10:25:57 : EWUSB: EW startup data line 02 1E 20 02 20 09 00 00 00
    2008-12-29 10:25:57 : EWUSB: EW startup data line 03 00 00 00 02 00 00 10 01
    2008-12-29 10:28:26 : PleaseWaitForm.Close executed
    2008-12-29 10:28:52 : Writing todayfile, LastUpdateTime = 29/12/2008 10:05:31 raindaystart = 51.5999984741211
    2008-12-29 10:28:52 : EWUSB: HidControl Device Unplug

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Download from Station stuck

    Post by steve » Mon 29 Dec 2008 11:01 am

    CumuFin wrote: callstack crc : $688f1aac, $9bffdddc, $a02b5ba2
    count : 2
    exception number : 1
    exception class : EAccessViolation
    exception message : Access violation at address 688F1AAC. Read of address 688F1AAC.
    I'm afraid that tells me very little, I need the whole bugreport.txt file - could you attach it, or email it to steve@sandaysoft.com if you prefer.

    Edit: Actually, looking at your initial post, this looks like the same thing. The last line in the Diags file suggests that the USB connection to the station has been lost, so Cumulus crashes when it tries to talk to it.

    2008-12-29 10:25:57 : EWUSB: EW startup data line 01 55 AA A0 20 A1 04 A0 20
    2008-12-29 10:25:57 : EWUSB: EW startup data line 02 55 AA FF FF FF FF FF FF
    2008-12-29 10:25:57 : EWUSB: EW startup data line 02 1E 20 02 20 09 00 00 00
    2008-12-29 10:25:57 : EWUSB: EW startup data line 03 00 00 00 02 00 00 10 01
    It looks like your station is now sending yet another different sequence of headers that Cumulus doesn't recognise :-(

    Could you try doing a full reset of the station?

    Steve

    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Re: Download from Station stuck

    Post by CumuFin » Mon 29 Dec 2008 2:17 pm

    i have cold started the device, ie. take the batteries out (only way). I have also re-installed the latest cumulus version after I de-installed and erased ini files etc.
    No luck,it is still stuck at the download stage.

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Download from Station stuck

    Post by steve » Mon 29 Dec 2008 2:51 pm

    Does the latest Diags file still look the same?

    Steve

    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Re: Download from Station stuck

    Post by CumuFin » Mon 29 Dec 2008 2:58 pm

    diag looks like this:

    2008-12-29 14:44:40 : Cumulus 1.8.4 Build 605 startup

    =============================== OS version info =================================
    Platform : Windows NT, Windows 2000, Windows XP, or Windows Server 2003 family.
    OS Name : Windows XP (Service Pack 3)
    (Major Version[ 5 ] Minor Version[ 1 ] Build Number[ 2600 ] Platform ID[ 2 ])
    ===================================================================================

    2008-12-29 14:44:40 : Showing main form
    2008-12-29 14:44:40 : Read today file: Date = 29/12/2008, LastUpdateTime = 29/12/2008 14:12:06
    2008-12-29 14:44:40 : Todayfileraindaystart = -1
    2008-12-29 14:44:40 : Todayfile is for today
    2008-12-29 14:44:40 : Read yesterday file: Date = 00/00/00
    2008-12-29 14:44:40 : EWUSB Form Create
    2008-12-29 14:44:40 : EWUSB: HidControl Arrival
    2008-12-29 14:44:40 : EWUSB: HidControl DeviceChange
    2008-12-29 14:44:42 : EWUSB: Initialising EW USB
    2008-12-29 14:44:42 : USB device, VID = 1941 PID = 8021
    2008-12-29 14:44:42 : EWUSB: Found Fine Offset station
    2008-12-29 14:44:42 : EWUSB: Get history data
    2008-12-29 14:44:42 : Request EW data block, addr = 000000
    2008-12-29 14:44:43 : EWUSB: EW startup data line 01 55 AA A0 20 A1 04 A0 20
    2008-12-29 14:44:43 : EWUSB: EW startup data line 02 55 AA FF FF FF FF FF FF
    2008-12-29 14:44:43 : EWUSB: EW startup data line 02 1E 20 02 30 09 00 00 00
    2008-12-29 14:44:43 : EWUSB: EW startup data line 03 81 00 00 02 00 00 10 01
    2008-12-29 14:44:55 : PleaseWaitForm.Close executed
    2008-12-29 14:45:04 : Writing todayfile, LastUpdateTime = 29/12/2008 14:12:06 raindaystart = -1
    2008-12-29 14:45:04 : EWUSB: HidControl Device Unplug

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Download from Station stuck

    Post by steve » Mon 29 Dec 2008 3:05 pm

    Thanks - the problem is that "55 AA" at the start of the second line of data. Those bytes are only supposed to appear at the start of the first line (or so I am told). Some users were having a problem where the first line was being repeated, so I put in a check to detect this and ignore the duplicate. In your case, it's not actually a duplicate.

    I'll put in an option (settable only by the cumulus.ini file for now) to turn off that duplicate checking.

    Steve

    User avatar
    steve
    Cumulus Author
    Posts: 26717
    Joined: Mon 02 Jun 2008 6:49 pm
    Weather Station: None
    Operating System: None
    Location: Vienne, France
    Contact:

    Re: Download from Station stuck

    Post by steve » Mon 29 Dec 2008 3:15 pm

    Give this a try please:

    http://www.nybbles.co.uk/downloads/beta ... sSetup.exe

    After installing, edit cumulus.ini, and in the [Station] section add:

    EWduplicatecheck=0

    Then start it up.

    Thanks,
    Steve

    CumuFin
    Posts: 8
    Joined: Fri 05 Dec 2008 6:15 pm

    Re: Download from Station stuck

    Post by CumuFin » Mon 29 Dec 2008 6:39 pm

    followed your instruction and cumulus has fired up and downloaded the data from the station ok. Phew.
    Trying to get the backup data in place now.
    Many thanks!!

    Post Reply