Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.11.4 (build 3133) - 25 May 2021 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

WH1080 Fine Offset station sets in error mode

Discussion specific to Fine Offset and similar rebadged weather stations
Post Reply
sm0ifp
Posts: 4
Joined: Fri 06 Oct 2017 3:49 am
Weather Station: wh1082
Operating System: Debian

WH1080 Fine Offset station sets in error mode

Post by sm0ifp »

Hi

I have a WH1080 Fine Offset station and it sets in error mode by CumulusMX.
The panel is setup in Celsius but CumulusMX change it to Farenheight for indor temp.
Have disconnected from CumulusMX and reset the station but it still stuck up in error mode when connected to raspberrypi.
I have the RaspberryPi image and updated to 3.10.2 build 3117.
The service is starting the mono version 4, manually start in /opt/CumulusMX start mono version 6.
The number 0 looks like "o" at the website

**********************************************************************************
pi@weatherpi:/opt/CumulusMX $ sudo mono CumulusMX.exe
Cumulus MX v.3.10.2 build 3117
Working Dir: /opt/CumulusMX/
Cumulus running at: http://*:8998/
(Replace * with any IP address on this machine, or localhost)
Open the admin interface by entering this URL in a browser.
Today.ini = data/today.ini
Last update=2021-02-28T21:20:00
Looking for Fine Offset station
Fine Offset station found
Connected to station
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
03/03/2021 01:45:19
Type Ctrl-C to terminate
Downloading Archive Data
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
Error reading data from station - it may need resetting
*********************************************************************************
Have used this program sinse 2013. first on Windows XP and now on RaspberryPi

Thanks for the program.

Jan Olof

http://privat.bahnhof.se/wb815306/weather/index.htm

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: WH1080 Fine Offset station sets in error mode

Post by mcrossley »

Are you sure you have selected the correct Fine Offset station type? There are two, depending if the station provides solar readings or not (NOTE: not if it is solar powered or not).

sm0ifp
Posts: 4
Joined: Fri 06 Oct 2017 3:49 am
Weather Station: wh1082
Operating System: Debian

Re: WH1080 Fine Offset station sets in error mode

Post by sm0ifp »

Sorry but no success to read data anymore.
Using Fine Offset with no solar panel, update time 10 min.
Raspberry pi is connected to the station but it it display "Error reading data from station - it may need resetting
".
I have used Easyweather from windows to reset the panel but no success.
Updated to Cumulus MX 3.10.5 b3122 but still the same error.
Started the application with and without service but same error.

Happy weather

Jan Olof

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: WH1080 Fine Offset station sets in error mode

Post by mcrossley »

Have you tried to power reset the console?

Remove power cable
Remove USB cable
Remove batteries
Wait 20 seconds
Replace cables and batteries

sm0ifp
Posts: 4
Joined: Fri 06 Oct 2017 3:49 am
Weather Station: wh1082
Operating System: Debian

Re: WH1080 Fine Offset station sets in error mode

Post by sm0ifp »

Thank you for the info of resetting the station.
Have it off power for 8 hour and now it seems to work with the new version 3.11.1 build 3130.

Happy weather

http://privat.bahnhof.se/wb815306/weather/index.htm

Jan Olof

User avatar
mcrossley
Posts: 8473
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2/WLL
Operating System: Buster Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: WH1080 Fine Offset station sets in error mode

Post by mcrossley »

:thumbsup:

Post Reply