Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

Missing data

Discussion specific to Fine Offset and similar rebadged weather stations
Post Reply
*Chris21*
Posts: 2
Joined: Sun 30 Jul 2017 12:33 pm
Weather Station: Aercus WS3083
Operating System: windows 7 SP1

Missing data

Post by *Chris21* » Sun 30 Jul 2017 1:10 pm

Hello,

I’m looking for some help with an error I have encountered when running Cumulus on my PC and importing data from my weather station.

I have been using Cumulus for a little over a year. I last plugged my weather station’s receiver into my laptop and ran Cumulus on 15th July and, as it usually does, Cumulus automatically imported all data received/stored since the previous time it was run, so far so good. Today I have repeated this process to back up all data received over the last 15 days. This is where I encountered a problem. Unfortunately my laptop simultaneously launched 2 episodes of Cumulus (I suspect that slow processing + my impatience may have been to blame here) and this appears to have created a problem in downloading the data - only 3 out of the last 15 days (19th-21st July) have been imported and some of that data looks a little unexpected.

I have searched the FAQ’s and forum for advice but can’t find anything that quite matches the problem I am faced with. I can see advice about adding missing lines to the dayfile.txt logs (but see this is manual entry). I also see some information regarding deleting all data and starting from scratch at the present point in time. I’ve tried picking relevant bits from this advice and manipulating the dayfile.txt logs for missing days or removing the Jul17log in the hope that it would force an update but this did not have the desired result so they have been returned to the state/locations they were in before I attempted to fix this problem.

What I ask is this: Is it possible to disregard/delete all data downloaded today (effectively returning it to its former state - as at 2 weeks ago) and therefore force Cumulus into downloading this time period again? The data for this date range is still currently stored on my weather stations receiver and therefore I really would like to get the most accurate figures for this time rather than manually entering estimates from the information I am able to see on its screen.

Thank you

User avatar
steve
Cumulus Author
Posts: 26714
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Missing data

Post by steve » Sun 30 Jul 2017 3:09 pm

Look in the backup folder for the backup which Cumulus took when it first started up today. Stop Cumulus, copy all of the files from that backup folder into the data folder (overwriting the files which are there) - this restores Cumulus to the state it was in before you ran it today. Start Cumulus and it should then download the data from July 15th onwards, to get up to date.
Steve

*Chris21*
Posts: 2
Joined: Sun 30 Jul 2017 12:33 pm
Weather Station: Aercus WS3083
Operating System: windows 7 SP1

Re: Missing data

Post by *Chris21* » Sat 05 Aug 2017 11:11 am

Thank you Steve. It's easy when you know where to look. I restored the initial backup files created on 30th July but this still threw in one of the 3 random dates so took another step back and restored the final backup files from the 15th July. This looks to have done the trick, thanks again.

Post Reply