Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.13.4 (build 3149) - 03 October 2021

Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of drop-down menus to 2030)

Download the Software (Cumulus MX / Cumulus 1 and other related items) from the Wiki

If you are interested in supporting Cumulus then maybe you would like to contribute to the maintenance of the Wiki? This need not take hours of your time - just a half hour here and there can make a big difference, particularly if many people are doing this. Any contributions are very welcome, whether they involve new content or editing of existing content. It will be very helpful to current and future users of Cumulus software if the Wiki is kept well-maintained and current. If you are interested then please contact forum user saratogaWX and ask for a Wiki account.

Data corruption on exit/restart of Cumulus

Discussion specific to Fine Offset and similar rebadged weather stations
Post Reply
dc1500
Posts: 242
Joined: Thu 04 Sep 2008 8:35 am
Weather Station: Watson W-8681 (Fine Offset type)
Operating System: Windows 10
Location: Laindon, S. Essex
Contact:

Data corruption on exit/restart of Cumulus

Post by dc1500 »

cumulus.zip
V 1.9.4 build 1099
Windows 10

Probably since migration to new PC running Windows 10 I am noticing data errors after <processing data >on restarting Cumulus after a program exit. Mostly ridiculously high rainfalls, dew points wind speeds.It seems to generally be in the last few logged entries, with a block of time missing at the end and about three odd lines with non-sequitor times. e.g
24/09/15,21:50,12.5,80,9.1,1,5,270,0.0,4.0,1018.4,541.5,19.9,64,0,12.5,12.5,0,356,0.00,0.00,11.9,0,17.8,0,0.0,4.0 normal at shutdown.
24/09/15,21:57,-0.3,31,-15.4,2,3,225,0.0,17625.0,0.0,15226.0,0.0,0,3,-0.3,-0.3,16,25,0.00,0.00,-4.4,0,19.4,225,0.0,17625.0 corrupt
24/09/15,22:36,-0.3,31,-15.4,2,3,225,0.0,17625.0,0.0,15226.0,2.0,7,3,-0.3,-0.3,16,25,0.00,0.00,-4.4,0,19.4,225,0.0,17625.0 corrupt
24/09/15,22:48,-0.3,2,-44.4,2,3,225,0.0,275.8,0.0,768.0,0.7,13,3,-0.3,-0.3,0,365,0.00,0.00,-4.4,0,19.6,225,0.0,275.8 corrupt

Then subsequent data is correct and runs perfectly after editing these out.
Diag files atached.

Help appreciated,
thanks, Dave C
You do not have the required permissions to view the files attached to this post.
Image

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Data corruption on exit/restart of Cumulus

Post by steve »

See the FAQ for this issue for possible explanations - http://wiki.sandaysoft.com/a/FAQ#I_get_ ... h_readings

In this case, the relevant explanation is that you have chosen the wrong station type in Cumulus; your station does not have solar sensors.
Steve

dc1500
Posts: 242
Joined: Thu 04 Sep 2008 8:35 am
Weather Station: Watson W-8681 (Fine Offset type)
Operating System: Windows 10
Location: Laindon, S. Essex
Contact:

Re: Data corruption on exit/restart of Cumulus

Post by dc1500 »

Okay thanks Steve. Doubt I would have spotted that after 5 years running. Must have crept in after the migration and re-installation.
Mind you I can now see "Sunshine hours" in <today> on my website.
Cheers,
Dave
Image

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: Data corruption on exit/restart of Cumulus

Post by steve »

dc1500 wrote:Mind you I can now see "Sunshine hours" in <today> on my website.
Yes - shame the figure is completely fictitious :)
Steve

Post Reply