Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.9.1 (build 3096) - 31 October 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

where did this rainfall come from?

Discussion specific to Fine Offset and similar rebadged weather stations
Post Reply
dpmiller
Posts: 48
Joined: Mon 30 May 2011 1:34 pm
Weather Station: WH3080
Operating System: Win XP sp3
Location: newtownards, N.I.

where did this rainfall come from?

Post by dpmiller »

So I downloaded the last few days data this evening and find a *record* rainfall spike of over 7k mm on Friday. It's showing in all the records, but I don't see any rainfall in dayfile to match it. Any ideas? Diags attached

David
You do not have the required permissions to view the files attached to this post.

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: where did this rainfall come from?

Post by steve »

I can't see any problems with rainfall in there, but with so much data to look through it would be easier with some clues as to which records exactly were recorded, with the timestamps. If an all-time record was broken, the last few lines of alltimelog.txt would be useful.

The station apparently became disconnected just after processing the logger data:

04/05/2014 21:50:00.578 : Writing today.ini, LastUpdateTime = 04/05/2014 21:50:00 raindaystart = 16.2000007629395 rain counter = 16.5
04/05/2014 21:50:00.578 : Latest reading: 24C8: Data: 03 44 CB 00 54 67 00 69 27 1F 29 00 08 37 00 00
04/05/2014 21:55:56.579 : 21:55:56 EWUSB: HidControl Device Unplug
04/05/2014 21:55:56.579 : VID = 1941 PID = 8021
04/05/2014 21:55:56.579 : Error - station unplugged - check connections
04/05/2014 21:55:56.580 : EWUSB: HidControl Device Removal

and it's apparently still disconnected:

04/05/2014 22:07:47.468 : 22:07:47 EWUSB: Initialising EW USB
04/05/2014 22:07:47.468 : 22:07:47 EWUSB: Looking for station...
04/05/2014 22:07:47.468 : 22:07:47 EWUSB: Fine Offset station not found!
Steve

dpmiller
Posts: 48
Joined: Mon 30 May 2011 1:34 pm
Weather Station: WH3080
Operating System: Win XP sp3
Location: newtownards, N.I.

Re: where did this rainfall come from?

Post by dpmiller »

Yes Steve, I only connect every few days and download data to have a look at, the LCD is fine for my realtime use. All rainfall records were allegedly broken @ 1013 on 2/5/14 with a value of 7431; but I don't see it in the dayfile for that date?

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: where did this rainfall come from?

Post by steve »

dpmiller wrote:Yes Steve, I only connect every few days and download data to have a look at
But my point is that you disconnected the station while Cumulus was still running; this is likely to cause problems.
All rainfall records were allegedly broken @ 1013 on 2/5/14 with a value of 7431; but I don't see it in the dayfile for that date?
Found it:

04/05/2014 21:43:20.185 : Writing today.ini, LastUpdateTime = 02/05/2014 10:08:29 raindaystart = 15.8999996185303 rain counter = 15.8999996185303
04/05/2014 21:43:20.198 : 21:43:20 EWUSB: Processing history data for = 02/05/2014 10:13:29
04/05/2014 21:43:20.256 : New monthly record, month = 5: 2014-05-02 10:13 7431.000 "High daily rain" 2014-05-01 00:00 6.000
04/05/2014 21:43:20.372 : New monthly record, month = 5: 2014-05-02 10:13 7437.000 "Highest monthly rainfall" 2014-05-01 00:00 6.000
04/05/2014 21:43:20.388 : Windrun: 5.6mph for 5 minutes = 0.5miles
04/05/2014 21:43:20.432 : Writing today.ini, LastUpdateTime = 02/05/2014 10:13:29 raindaystart = 15.8999996185303 rain counter = 7446.89990234375
04/05/2014 21:43:20.535 : Windrun: 5.4mph for 5 minutes = 0.4miles
04/05/2014 21:43:20.581 : Writing today.ini, LastUpdateTime = 02/05/2014 10:18:29 raindaystart = 15.8999996185303 rain counter = 15.8999996185303

There was a sudden jump in the rain counter. Normally there would be an error message there, I don't know why there isn't, but there is something odd going on with your system, the entries in the diags log don't make sense, they appear to be out of sequence. And there's no sign of any rain records being broken at that point. It's a bit like there's a second instance of Cumulus running at the same time; I think this is the most likely explanation. But the erroneous rainfall figure was apparently in the logger entry.
Steve

dpmiller
Posts: 48
Joined: Mon 30 May 2011 1:34 pm
Weather Station: WH3080
Operating System: Win XP sp3
Location: newtownards, N.I.

Re: where did this rainfall come from?

Post by dpmiller »

Most odd. The laptop had been freshly booted yesterday, so I can't see how there could've been more than one instance of the program running

At least I now know where it came from and can do something about it

Oh, and I take your comment on board about disconnection. I tend to unplug on completion of logger file updating and have never seen a problem, but I'll be careful in future...

User avatar
steve
Cumulus Author
Posts: 26702
Joined: Mon 02 Jun 2008 6:49 pm
Weather Station: None
Operating System: None
Location: Vienne, France
Contact:

Re: where did this rainfall come from?

Post by steve »

It's just a guess about multiple instances; the diags file is in such an odd state that I can't think of a better explanation.
Steve

Post Reply