Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.8.4 (build 3094) - 14 September 2020 (please see announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

Use this Wiki link to Download the Software (Cumulus MX / Cumulus 1 and other related items).

Maplin Weather station N96GY (WH1081) display not working

Talk about anything that doesn't fit elsewhere - PLEASE don't put Cumulus queries in here!
Post Reply
Wstat
Posts: 3
Joined: Tue 14 Jan 2020 11:45 pm
Weather Station: N96GY
Operating System: Windows 7

Maplin Weather station N96GY (WH1081) display not working

Post by Wstat »

Hi all,

I bought new in box Maplin Weather station N96GY (WH1081) from car boot sell. Unfortunately console display doesn't work...
When I put the batteries in, all digit segments and LEDs come on for a 1-2 sec (like initial test) and everything disappear, screen is clear, nothing on it.
My questions are:

1. Is that common known problem?

2. Is it hardware or software problem?

3. Generally is it possible to update the firmware?

Any solution please?
Thanks

User avatar
LAdrain
Posts: 23
Joined: Tue 03 Jul 2012 5:22 pm
Weather Station: davis vantage vue
Operating System: Windows 10
Location: Shropshire
Contact:

Re: Maplin Weather station N96GY (WH1081) display not working

Post by LAdrain »

With my old one the ribbon cable had split inside the unit. Worth checking it is in the socket correctly by removing the screws on the back.

Wstat
Posts: 3
Joined: Tue 14 Jan 2020 11:45 pm
Weather Station: N96GY
Operating System: Windows 7

Re: Maplin Weather station N96GY (WH1081) display not working

Post by Wstat »

Thanks LAdrain
Will check it, but was the same effect before you fixed it?
When connect it via USB cable, PC installed drivers but I can't see it in W. Explorer or somewhere in Device manager, just known sound when plug in/out.
I've got electronics background, oscilloscope, but don't know what to check when open it...

User avatar
jimi
Posts: 23
Joined: Sun 29 Sep 2013 11:06 am
Weather Station: Fine Offset WH1081
Operating System: Windows 7
Location: Glenrothes: The Kingdom of Fife
Contact:

Re: Maplin Weather station N96GY (WH1081) display not working

Post by jimi »

It won't show up in windows explorer and will only sbow in device manager as a HID-compliant device but not identified any other way. Try opening device manager, then plugging/unplugging it to see if anything is added under Human Interface Devices. If it is download Easyweather and see if it will connect to the station.
(that's for win7 or earlier, can't say for win8 or win10)
Black is not a colour ! .... Its the absence of colour
Image

Wstat
Posts: 3
Joined: Tue 14 Jan 2020 11:45 pm
Weather Station: N96GY
Operating System: Windows 7

Re: Maplin Weather station N96GY (WH1081) display not working

Post by Wstat »

jimi wrote:
Tue 21 Jan 2020 5:55 pm
It won't show up in windows explorer and will only sbow in device manager as a HID-compliant device but not identified any other way. Try opening device manager, then plugging/unplugging it to see if anything is added under Human Interface Devices. If it is download Easyweather and see if it will connect to the station.
(that's for win7 or earlier, can't say for win8 or win10)
Yes it registered in D. Manager in HID but in Easyweather appeared just Pressure (I think even without batteries in sender)...
Anyway I gave up...

Post Reply