Welcome to the new home of the Cumulus Support forum.

Latest Cumulus release v1.9.4 (build 1099) - Nov 28 2014
Latest Cumulus MX release - v3.0.0 build 3044 7 December 2018. See the Wiki for download

New Cumulus Home

Talk about anything that doesn't fit elsewhere - PLEASE don't put Cumulus queries in here!
freddie
Posts: 329
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Ystrad, Rhondda, Wales
Contact:

Re: New Cumulus Home

Post by freddie » Tue 06 Nov 2018 7:31 pm

weatherist34 wrote:
Tue 06 Nov 2018 11:39 am
video of timeframe to login
That is awful :-(
Are you able to tell me the date/time of occurrence (UTC)?

Thanks,
Freddie
Image

freddie
Posts: 329
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Ystrad, Rhondda, Wales
Contact:

Re: New Cumulus Home

Post by freddie » Tue 06 Nov 2018 7:39 pm

weatherist34 wrote:
Tue 06 Nov 2018 6:08 pm
yes i agree something is better than nothing but in comparison to any other forum,new forum site is painfully slow to actually use almost to point of (as harsh as that sounds) unuseable. i guess start up teeting issues and works ok for some and not good some .

just now

20 second login aprox

click on this post another 30 seconds to appear for reading

click on post reply another 20 seconds to get to window

total aprox 70 seconds to get to the reply form ,thats before typing a response/reply

i find it quicker to read post not logged in as they appear instantanousely .


just really highlighing the issue not being un appreciative for the offering of this site and im sure with some closer inspection of code/configuration it will get resolved. FWIW three years ago i migrated a hotel portal to a new domain very similar start up issues and slow performance eventually traced down to three hardcoded scripts to the old domain <script src= http://oldmain.com/somejquery.js> for example .not saying thats the issue but until looking closer we would never have discovered it has it wasnt flagged in the console error logs as the old domain was still active.

ps i had to edit after posting another 30 seconds to get back to here.
Thanks for highlighting this. I have checked against server (both web and db) performance for the time period 18:00 UTC to 18:08 UTC (based on the timing of this post) and the metrics I see don't suggest a problem with the servers themselves (relatively low CPU - some spikes on db, but that is normal - and memory usage well within physical memory settings) so I am puzzled at the moment. I need to collect some more data.

Regards,
Freddie
Image

User avatar
mcrossley
Posts: 5234
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: New Cumulus Home

Post by mcrossley » Tue 06 Nov 2018 7:45 pm

Maybe someone with issues could show a F12 network trace from their browser. Here is mine (cache disabled) for clicking the "Unread" posts button.

Bulk of the 2.41 secs was the initial search.php at 1.71 secs
unreadPosts.png
You do not have the required permissions to view the files attached to this post.

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: New Cumulus Home

Post by ConligWX » Tue 06 Nov 2018 8:10 pm

freddie wrote:
Tue 06 Nov 2018 7:27 pm
No, I don't. Also, this would only impact on performance for users registering

Code: Select all

If you still want to use it for registrations but not for submitting a post then open /posting.php and find:
CODE: SELECT ALL

	// DNSBL check
	if ($config['check_dnsbl'] && !$refresh)
	{
		if (($dnsbl = $user->check_dnsbl('post')) !== false)
		{
			$error[] = sprintf($user->lang['IP_BLACKLISTED'], $user->ip, $dnsbl[1]);
		}
	}
that was in the link I provided. so if blacklisting is on it check for user registrations AND posts.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

freddie
Posts: 329
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Ystrad, Rhondda, Wales
Contact:

Re: New Cumulus Home

Post by freddie » Tue 06 Nov 2018 8:23 pm

ConligWX wrote:
Tue 06 Nov 2018 8:10 pm
freddie wrote:
Tue 06 Nov 2018 7:27 pm
No, I don't. Also, this would only impact on performance for users registering

Code: Select all

If you still want to use it for registrations but not for submitting a post then open /posting.php and find:
CODE: SELECT ALL

	// DNSBL check
	if ($config['check_dnsbl'] && !$refresh)
	{
		if (($dnsbl = $user->check_dnsbl('post')) !== false)
		{
			$error[] = sprintf($user->lang['IP_BLACKLISTED'], $user->ip, $dnsbl[1]);
		}
	}
that was in the link I provided. so if blacklisting is on it check for user registrations AND posts.
Ah okay thanks - I didn't read the article, I just knew that the setting was off. If that is the code in use then I will never turn it on :-)
Freddie
Image

M1DUL
Posts: 260
Joined: Wed 31 Dec 2008 1:56 pm
Weather Station: W-8681 Solar Weather Station
Operating System: Windows 10 Pro 64bit Build 10586
Location: Poole, Dorset UK
Contact:

Re: New Cumulus Home

Post by M1DUL » Tue 06 Nov 2018 9:16 pm

I am having this slow problem all the time here is my F12 network trace. (cache disabled)
I am on Sky Fibre Unlimited I hope this is helpful to fix this problem UTC time 21:15

Devtools.png
You do not have the required permissions to view the files attached to this post.

User avatar
mcrossley
Posts: 5234
Joined: Thu 07 Jan 2010 9:44 pm
Weather Station: Davis VP2
Operating System: Stretch Lite rPi
Location: Wilmslow, Cheshire, UK
Contact:

Re: New Cumulus Home

Post by mcrossley » Tue 06 Nov 2018 9:24 pm

OK, so that shows the delay is definitely in the server, 15 secs to process that initial request. Rules out routing/network etc.

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: New Cumulus Home

Post by ConligWX » Tue 06 Nov 2018 9:34 pm

just curious are there any overheads in the database that need optimized perhaps?
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

User avatar
Super-T
Posts: 803
Joined: Tue 09 Sep 2008 3:37 am
Weather Station: wh-1081
Operating System: Weather Laptop - Windows 10 Pro
Location: Auckland, New Zealand
Contact:

Re: New Cumulus Home

Post by Super-T » Tue 06 Nov 2018 9:46 pm

All seems to working OK out of NZ, using firefox. Maybe a tad slower but hardly noticeable.

User avatar
HRVistaWeather
Posts: 179
Joined: Mon 09 Apr 2012 2:38 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 Home (64bit)
Location: Franklin, Huon Valley, Tasmania
Contact:

Re: New Cumulus Home

Post by HRVistaWeather » Tue 06 Nov 2018 11:16 pm

Hi (from down in Tasmania/Australia on NBN Fixed Wireless Download speed around 25mbsp).
My F12 network trace. (cache disabled)
IUTC time around 22:50 (while logged on - clicking on Un-Read Button).
cumulusunreadbutton.PNG
Kind Regards,
You do not have the required permissions to view the files attached to this post.
Tony
Huon River Vista - South Franklin Weather - Tasmania
Davis Vantage Pro 2 Plus - FARS, Cumulus MX, 2 Soil Temp/Moist Solar/Rad.
Image

Turvey
Posts: 20
Joined: Sun 12 Jul 2015 12:07 pm
Weather Station: Vantage Vue
Operating System: Win 7
Location: Kirkwall, Orkney

Re: New Cumulus Home

Post by Turvey » Tue 06 Nov 2018 11:19 pm

Running Chrome on my phone, no slow issues as far as I can see.

Just checked on PC running Chrome, no issues.

User avatar
Ned
Posts: 226
Joined: Mon 19 Jul 2010 11:15 am
Weather Station: WS2083 aspirated
Operating System: Win 10
Location: Auckland NZ
Contact:

Re: New Cumulus Home

Post by Ned » Wed 14 Nov 2018 3:10 am

Any developments on trying to fix the slow page loads? I'm still having a 15 second delay every time, anytime I log on :bash:

User avatar
HRVistaWeather
Posts: 179
Joined: Mon 09 Apr 2012 2:38 pm
Weather Station: Davis VP2 Plus - 24hr FARS
Operating System: Windows 10 Home (64bit)
Location: Franklin, Huon Valley, Tasmania
Contact:

Re: New Cumulus Home

Post by HRVistaWeather » Wed 14 Nov 2018 3:44 am

Dito Ned,
Still same here also, no change still slow. I find I am just reading odd posts not logged in as quicker.
regards,
Tony
Huon River Vista - South Franklin Weather - Tasmania
Davis Vantage Pro 2 Plus - FARS, Cumulus MX, 2 Soil Temp/Moist Solar/Rad.
Image

User avatar
ConligWX
Posts: 736
Joined: Mon 19 May 2014 10:45 pm
Weather Station: Davis Vantage Pro2 Plus
Operating System: MeteoBridge Nano SD
Location: Bangor, NI
Contact:

Re: New Cumulus Home

Post by ConligWX » Wed 14 Nov 2018 7:55 am

Freddie, Do you have Sphinx Fulltext Search index installed?

https://wiki.phpbb.com/Sphinx_Fulltext_Search

might be worth installing it or re-running the indexing.
Regards Simon

https://www.conligwx.org
https://twitter.com/conligwx
Davis Vantage Pro2 Plus - Meteobrige Nano SD + Saratoga/PWS Templates

freddie
Posts: 329
Joined: Wed 08 Jun 2011 11:19 am
Weather Station: Davis Vantage Pro 2
Operating System: GNU/Linux (Ubuntu 18.04)
Location: Ystrad, Rhondda, Wales
Contact:

Re: New Cumulus Home

Post by freddie » Wed 14 Nov 2018 9:30 am

Ned wrote:
Wed 14 Nov 2018 3:10 am
Any developments on trying to fix the slow page loads? I'm still having a 15 second delay every time, anytime I log on :bash:
I have made some adjustments (more resources for both web and database server, and a change to the network topology between the two) and am currently assessing those changes. I tend to gradually tweak so I can understand the implications of each tweak.

The observation of slow logins and a difference in loading times (logged in v not logged in) is a tricky one to thrash out, as only some users experience this. It doesn't appear to be browser-specific (or even location-specific) so I'm still thinking hard about that aspect.

Thanks for your patience!
Freddie
Image

Post Reply