Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.2.4 build 3060 - 10 December 2019.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    New Cumulus Home

    Talk about anything that doesn't fit elsewhere - PLEASE don't put Cumulus queries in here!
    BCJKiwi
    Posts: 885
    Joined: Mon 09 Jul 2012 8:40 pm
    Weather Station: Davis VP2 Cabled with Solar
    Operating System: Windows 10 Pro
    Location: Auckland, New Zealand
    Contact:

    Re: New Cumulus Home

    Post by BCJKiwi » Tue 06 Nov 2018 3:46 am

    All the way from New Zealand:-
    I have changed the url to;
    https://cumulus.hosiene.co.uk
    and that works fine.

    Just tried the old url which was slow when the site was first changed over but now it is the same speed as the new url.

    However the odd menu item here and there is slow when in logged in.

    weatherist34
    Posts: 105
    Joined: Wed 13 Apr 2016 11:09 am
    Weather Station: Davis Vantage Pro2 Plus
    Operating System: OSX High Sierra
    Contact:

    Re: New Cumulus Home

    Post by weatherist34 » Tue 06 Nov 2018 11:39 am


    M1DUL
    Posts: 269
    Joined: Wed 31 Dec 2008 1:56 pm
    Weather Station: Vantage Pro2 Plus Daytime FARS
    Operating System: Windows 10 Pro 64bit Build 10586
    Location: Poole, Dorset UK
    Contact:

    Re: New Cumulus Home

    Post by M1DUL » Tue 06 Nov 2018 12:14 pm

    weatherist34 wrote:
    Tue 06 Nov 2018 11:39 am
    video of timeframe to login

    https://www.youtube.com/watch?v=2JVQWEpGVtI
    Thank you for showing the video of how slow the server is.
    I have noticed that the site is very quick if you are not logged in, but as soon as you log in it takes 15-20 seconds to do anything like click on message or even posting messages or even to refreshing the page takes 15-20 seconds.
    Mike

    OS : Windows 10 Professionnal
    Weather Station : Davis Vantage PRO2 Plus Daytime Fars
    Cumulus MX version 3.00 b 3050
    http://branksomeweather.co.uk

    User avatar
    ConligWX
    Posts: 751
    Joined: Mon 19 May 2014 10:45 pm
    Weather Station: Davis VPro2 Plus +DFARS
    Operating System: MeteoBridge Nano SD
    Location: Bangor, NI
    Contact:

    Re: New Cumulus Home

    Post by ConligWX » Tue 06 Nov 2018 12:23 pm

    M1DUL wrote:
    Tue 06 Nov 2018 12:14 pm
    Thank you for showing the video of how slow the server is.
    I have noticed that the site is very quick if you are not logged in, but as soon as you log in it takes 15-20 seconds to do anything like click on message or even posting messages or even to refreshing the page takes 15-20 seconds.
    1 second to login. lets see the post time after submitting....
    Regards Simon

    https://www.conligwx.org - @conligwx
    Davis Vantage Pro2 Plus + DFARS - Meteobrige Nano SD + Saratoga Templates

    User avatar
    ConligWX
    Posts: 751
    Joined: Mon 19 May 2014 10:45 pm
    Weather Station: Davis VPro2 Plus +DFARS
    Operating System: MeteoBridge Nano SD
    Location: Bangor, NI
    Contact:

    Re: New Cumulus Home

    Post by ConligWX » Tue 06 Nov 2018 12:23 pm

    ConligWX wrote:
    Tue 06 Nov 2018 12:23 pm
    1 second to login. lets see the post time after submitting....
    3-5 Seconds. either re-editing or submitting a new post.
    Regards Simon

    https://www.conligwx.org - @conligwx
    Davis Vantage Pro2 Plus + DFARS - Meteobrige Nano SD + Saratoga Templates

    User avatar
    ConligWX
    Posts: 751
    Joined: Mon 19 May 2014 10:45 pm
    Weather Station: Davis VPro2 Plus +DFARS
    Operating System: MeteoBridge Nano SD
    Location: Bangor, NI
    Contact:

    Re: New Cumulus Home

    Post by ConligWX » Tue 06 Nov 2018 12:29 pm

    Freddie do you have

    Setting: "Check IP against DNS Blackhole list" enabled by any chance?

    https://www.phpbb.com/community/viewtop ... #p14932581

    you may also want to turn off TLS 1.0 on your server.

    https://www.ssllabs.com/ssltest/analyze ... iene.co.uk
    Regards Simon

    https://www.conligwx.org - @conligwx
    Davis Vantage Pro2 Plus + DFARS - Meteobrige Nano SD + Saratoga Templates

    M1DUL
    Posts: 269
    Joined: Wed 31 Dec 2008 1:56 pm
    Weather Station: Vantage Pro2 Plus Daytime FARS
    Operating System: Windows 10 Pro 64bit Build 10586
    Location: Poole, Dorset UK
    Contact:

    Re: New Cumulus Home

    Post by M1DUL » Tue 06 Nov 2018 12:38 pm

    ConligWX wrote:
    Tue 06 Nov 2018 12:23 pm
    ConligWX wrote:
    Tue 06 Nov 2018 12:23 pm
    1 second to login. lets see the post time after submitting....
    3-5 Seconds. either re-editing or submitting a new post.
    You are one of the Lucky ones then. all the other forums and website I go on are all quick. Just this site is slow for me and for some of the others members.
    Mike

    OS : Windows 10 Professionnal
    Weather Station : Davis Vantage PRO2 Plus Daytime Fars
    Cumulus MX version 3.00 b 3050
    http://branksomeweather.co.uk

    RayProudfoot
    Posts: 2714
    Joined: Wed 06 May 2009 6:29 pm
    Weather Station: Davis VP2 with Daytime FARS
    Operating System: Windows XP SP3
    Location: Cheadle Hulme, Cheshire, England
    Contact:

    Re: New Cumulus Home

    Post by RayProudfoot » Tue 06 Nov 2018 1:42 pm

    I can live with slow logins and presentation of the forum. Probably some setting that needs changing.

    The alternative of not having it is much much worse.
    Cheers,
    Ray, Cheshire.

    Image

    sutne
    Posts: 17
    Joined: Sun 14 Oct 2012 4:23 pm
    Weather Station: Oregon Scientific WMR100
    Operating System: Raspbian Jessie
    Location: Mjølfjell, Voss, Norway

    Re: New Cumulus Home

    Post by sutne » Tue 06 Nov 2018 1:55 pm

    From Norway I have no problems with the new site. Same quick response as the old site.

    And I am very thankful to the people that has set up the site and continues the good work that Steve started.
    :D

    water01
    Posts: 1558
    Joined: Sat 13 Aug 2011 9:33 am
    Weather Station: WH1081
    Operating System: Windows 7 64bit HP SP1
    Location: Somewhere in the USA
    Contact:

    Re: New Cumulus Home

    Post by water01 » Tue 06 Nov 2018 2:00 pm

    Same here in Texas.

    I know that Freddie is looking into the response times as part of the bedding in process of the new forum, so please have patience. There is no miracle cure just slow and methodical changes to check improvements do not cause other problems.

    As Ray says, it is better to have a slower site than no site at all!!

    weatherist34
    Posts: 105
    Joined: Wed 13 Apr 2016 11:09 am
    Weather Station: Davis Vantage Pro2 Plus
    Operating System: OSX High Sierra
    Contact:

    Re: New Cumulus Home

    Post by weatherist34 » Tue 06 Nov 2018 6:08 pm

    yes i agree something is better than nothing but in comparison to any other forum,new forum site is painfully slow to actually use almost to point of (as harsh as that sounds) unuseable. i guess start up teeting issues and works ok for some and not good some .

    just now

    20 second login aprox

    click on this post another 30 seconds to appear for reading

    click on post reply another 20 seconds to get to window

    total aprox 70 seconds to get to the reply form ,thats before typing a response/reply

    i find it quicker to read post not logged in as they appear instantanousely .


    just really highlighing the issue not being un appreciative for the offering of this site and im sure with some closer inspection of code/configuration it will get resolved. FWIW three years ago i migrated a hotel portal to a new domain very similar start up issues and slow performance eventually traced down to three hardcoded scripts to the old domain <script src= http://oldmain.com/somejquery.js> for example .not saying thats the issue but until looking closer we would never have discovered it has it wasnt flagged in the console error logs as the old domain was still active.

    ps i had to edit after posting another 30 seconds to get back to here.

    freddie
    Posts: 521
    Joined: Wed 08 Jun 2011 11:19 am
    Weather Station: Davis Vantage Pro 2
    Operating System: GNU/Linux (Ubuntu 18.04)
    Location: Dorrington, Shropshire
    Contact:

    Re: New Cumulus Home

    Post by freddie » Tue 06 Nov 2018 6:30 pm

    Thanks for all the responses on this thread. Apologies for no replies today but I have been tied up with real-life stuff (funeral).

    User's experiences of performance are very varied, and cannot simply be linked to server response. I have implemented the following changes:
    • Use gzip compression in all responses
    • Change board config to perform housekeeping tasks offline rather than interweaved with user requests
    CPU usage on the web server is minimal and bandwidth certainly isn't a problem.

    The database sits on another host (to keep the hosting cost-neutral for me). I'm aware of the following issues:
    • An intermittent (network?) issue that causes database call time-outs - but it is very intermittent so not a problem most of the time.
    • More memory could be added to the database host.
    • CPU on the database host appears adequate. I will look at provisioning further CPU capacity if necessary.
    There does appear to be a random element to the slowness experience which is puzzling me. It doesn't appear to be browser-specific as different users have different experiences with particular browsers. Routeing has been suggested as a potential candidate.

    I'll keep on with the slow and steady tweaking of what I can tweak. Continued feedback would be most welcome. If you do give feedback, could you please include the approximate time (in UTC) of the occurrence of poor performance ("all the time" isn't particularly helpful) and I will investigate further.

    Thanks,
    Freddie
    Image

    Mapantz
    Posts: 640
    Joined: Sat 17 Dec 2011 11:55 am
    Weather Station: Davis Vantage Pro2
    Operating System: Windows 10 x64
    Location: Dorset - UK
    Contact:

    Re: New Cumulus Home

    Post by Mapantz » Tue 06 Nov 2018 6:47 pm

    freddie wrote:
    Tue 06 Nov 2018 6:30 pm
    ("all the time" isn't particularly helpful)
    I can't help you then, as it is all the time for me, whether it's on my mobile or my tablet or my PC, each time I make a visit, it's slow as hell. :?
    Image

    freddie
    Posts: 521
    Joined: Wed 08 Jun 2011 11:19 am
    Weather Station: Davis Vantage Pro 2
    Operating System: GNU/Linux (Ubuntu 18.04)
    Location: Dorrington, Shropshire
    Contact:

    Re: New Cumulus Home

    Post by freddie » Tue 06 Nov 2018 7:16 pm

    Mapantz wrote:
    Tue 06 Nov 2018 6:47 pm
    freddie wrote:
    Tue 06 Nov 2018 6:30 pm
    ("all the time" isn't particularly helpful)
    I can't help you then, as it is all the time for me, whether it's on my mobile or my tablet or my PC, each time I make a visit, it's slow as hell. :?
    Can you not supply a time that you were using the forum? It would help me with looking at the web server and database logs, and cross-referencing CPU and memory usage graphs for that time.
    Also - do you experience slowness regardless of the network you are connected to?

    Thanks,
    Freddie
    Image

    freddie
    Posts: 521
    Joined: Wed 08 Jun 2011 11:19 am
    Weather Station: Davis Vantage Pro 2
    Operating System: GNU/Linux (Ubuntu 18.04)
    Location: Dorrington, Shropshire
    Contact:

    Re: New Cumulus Home

    Post by freddie » Tue 06 Nov 2018 7:27 pm

    ConligWX wrote:
    Tue 06 Nov 2018 12:29 pm
    Freddie do you have

    Setting: "Check IP against DNS Blackhole list" enabled by any chance?
    No, I don't. Also, this would only impact on performance for users registering.
    ConligWX wrote:
    Tue 06 Nov 2018 12:29 pm
    you may also want to turn off TLS 1.0 on your server.
    It's on the list - although I don't believe it would cause performance gains.
    Freddie
    Image

    Post Reply