Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3048 - 02 March 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Ephemeral Port Exhaustion

Talk about anything that doesn't fit elsewhere - PLEASE don't put Cumulus queries in here!
Post Reply
Posts: 6
Joined: Mon 24 Aug 2015 4:39 pm
Weather Station: Davis Vantage Vue
Operating System: Windows 2003 server
Location: Woodstock, GA, USA

Ephemeral Port Exhaustion

Post by bri-ko » Sun 25 Mar 2018 8:57 pm

I'm using Cumulus 1.9.4 on a windows 10 machine and have been for years. Everything has worked fine till last week. I tried to connect to my web site and check the Cumulus readings and was advised that the web site hadn't been updated for about 10 hours. I logged into the computer I used for my Cumulus software and when I brought Cumulus into focus saw that there were FTP errors.

I started checking and was unable to connect to any web addresses. I started the windows network trouble shooter but it came back saying that there were no troubles found. I restarted the machine and the network came back. Next day I found the same problem. Still the trouble shooter said no problems detected. I started checking logs and found a number of errors with "Ephemeral Port Exhaustion".

I thought that it may be associated with Cumulus as I have my FTP link to my web site set to 5 seconds. Maybe the rapid request for binding was using up the ports quicker that they could be given back.

I'm wondering it any of you may have run into this problem? By accident I may have fixed it as I haven't seen this error or it's effects for several days. I'd appreciate any feed back you may have.

Thanks much,

User avatar
Posts: 500
Joined: Sun 25 Jan 2015 8:41 pm
Weather Station: Davis Vantage Vue
Operating System: raspberry pi 3 +
Location: Worthing

Re: Ephemeral Port Exhaustion

Post by dazza1223 » Wed 28 Mar 2018 12:29 pm

as i work in a PC shop i see a lot off the problems with windows 10 the only way around the problem is to remove all the network drivers in device manager but im not with a windows 10 PC at the mo but let me know if it worked as there might be a nother way! .......PS sorry for got to say when u removed the drivers make sure u reboot the PC
Have fun and keep learning

dazza :D

Post Reply