Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Search found 213 matches

by BigOkie
Thu 12 Jan 2017 4:24 am
Forum: Cumulus MX
Topic: Wind problems
Replies: 11
Views: 1033

Re: Wind problems

Turning LOOP2 off has helped, but I'm still getting some intermittent null direction readings(360). Are there any other settings I might tweak to see if I can improve performance? Regards. You don't have the setting for 'Use bearing zero when wind calm' set do you? Are you getting those readings wh...
by BigOkie
Wed 11 Jan 2017 4:03 pm
Forum: Saratoga Templates
Topic: Saratoga Templates with PHP 7
Replies: 52
Views: 11237

Re: Saratoga Templates with PHP 7

My Saratoga website isn't WAN accessible (without firewall modifications as I can access my network from the WAN) but I put 7.0.1 on the Pi I'm running the webserver on and it seems ok. I don't access it a lot, but the only deprecated message I could find was related to Cumulus server side graphs an...
by BigOkie
Mon 09 Jan 2017 9:16 pm
Forum: Cumulus 1 (discontinued)
Topic: Error in dayfile.txt
Replies: 8
Views: 1034

Re: Error in dayfile.txt

mcrossley wrote:Notepad++ is fine, it lets you use RegEx's for search and replace - you may have to select an search option to enable them... Its a long time since I used Notepad++.
Yes, you have to select the regex option.
by BigOkie
Mon 09 Jan 2017 3:51 pm
Forum: Cumulus MX
Topic: Windows 10 issues
Replies: 10
Views: 820

Re: Windows 10 issues

Station type not set.

You will need to set that in the Settings > Station Settings menu of CumulusMX. It's the very first option.
by BigOkie
Fri 30 Dec 2016 6:00 pm
Forum: Cumulus MX
Topic: Fine Offset station not found weather station Dream Link WH1080 Weather Station
Replies: 31
Views: 5565

Re: Fine Offset station not found weather station Dream Link WH1080 Weather Station

Hi, Yes it is Linux, Opensuse 42.2, on a standard Intel i5 chipset with 8 Gb of RAM Linux comport designators don't use COMXX like windows. Depending on the distro it's going to be something like /dev/ttyUSBx (where x is a number). Some distros don't do it that way depending on how they read the po...
by BigOkie
Fri 30 Dec 2016 2:24 am
Forum: Cumulus MX
Topic: Fine Offset station not found weather station Dream Link WH1080 Weather Station
Replies: 31
Views: 5565

Re: Fine Offset station not found weather station Dream Link WH1080 Weather Station

Hi, I have a similar problem, "Fine Offset Station Not found" when I start CumulusMX, it was working up to 8th December when I upgraded the OS I use. (Opensuse 42.1 -> Opensuse 42.2). when I start CumulusMX I see this (I am running this as a root user) # mono CumulusMX.exe Current culture: English ...
by BigOkie
Sat 17 Dec 2016 7:35 pm
Forum: Cumulus MX
Topic: Wind spike ignored
Replies: 26
Views: 2346

Re: Wind spike ignored

Well, it did it a couple of times over the last two days. I'm finding out it does it for about five minutes then things seem ok again. This time the wind was pretty good for this. Like I said though, it may well have always been doing this, but I never had debug logging turned on very often. It alwa...
by BigOkie
Sat 17 Dec 2016 1:46 pm
Forum: Cumulus MX
Topic: udev rules document for RPI 3
Replies: 16
Views: 7118

Re: udev rules document for RPI 3

Has it something to do with user rights on my Raspberry ? I know very little about the Raspberry system. I have downlodet Steves files and installed them on a new Raspberry PI 3 Model B. At the beginning I always started it with the command: sudo mono CumulusMX.exe Later I wrote: cd CumulusMX sudo ...
by BigOkie
Fri 16 Dec 2016 7:05 pm
Forum: Cumulus MX
Topic: udev rules document for RPI 3
Replies: 16
Views: 7118

Re: udev rules document for RPI 3

If it's not connected to a station, then it won't be providing any data to the tag. This only works if you have a live connection. Not sure if it helps but the remote filename for the webtag file is /var/log/datatag.txt. not /home/pi/var/log/datatag.txt As I stated also, the tag generated will only ...
by BigOkie
Thu 15 Dec 2016 9:03 pm
Forum: Cumulus MX
Topic: RaspberryPi Davis Pro 2 USB Port
Replies: 5
Views: 871

Re: RaspberryPi Davis Pro 2 USB Port

Also, and just being clear, are you running a Linux distribution on your Pi? I know some are now using Win10 IOT on it. That won't work.
by BigOkie
Thu 15 Dec 2016 9:02 pm
Forum: Cumulus MX
Topic: RaspberryPi Davis Pro 2 USB Port
Replies: 5
Views: 871

Re: RaspberryPi Davis Pro 2 USB Port

Typically, yes...but you need to make sure once plugged in. It may not always enumerate it to the first.

issue this command at a Pi shell prompt:

ls /dev/ttyUSB*

and see what it returns. After you plug it in of course.
by BigOkie
Thu 15 Dec 2016 8:27 pm
Forum: Cumulus MX
Topic: udev rules document for RPI 3
Replies: 16
Views: 7118

Re: udev rules document for RPI 3

It's actually pretty simple. I've laid out how to do this in the posts. Take the contents of the first code window and put it in a file (I think I called mine checkmx.sh) and make sure to chmod +x that file so it can execute. From the second code window, place that in a file somewhere in the web dir...
by BigOkie
Wed 14 Dec 2016 10:21 pm
Forum: Cumulus MX
Topic: Wind spike ignored
Replies: 26
Views: 2346

Re: Wind spike ignored

It looks like the console was getting the current wind speeds - very low ones, but they are changing, so it is presumably getting new values - but for some reason the console was unable to provide the 10-minute average speed. Could that be due to a resync? I mean it's likely it may have always done...
by BigOkie
Wed 14 Dec 2016 7:31 pm
Forum: Cumulus MX
Topic: Wind spike ignored
Replies: 26
Views: 2346

Re: Wind spike ignored

I know this is a very old post, but I started seeing this happening this morning by chance. I just happened to have debug set in the logging and got this: 2016-12-14 08:56:10.787 !!! loop data not received 2016-12-14 08:56:10.988 Sending command LPS 2 1 - pass 1 2016-12-14 08:56:11.488 Wait for ACK ...
by BigOkie
Wed 07 Dec 2016 6:33 pm
Forum: Cumulus MX
Topic: Re: CumulusMX - Trojan/Malware In DLL ? - Nope, Defender Reporting False Positive
Replies: 9
Views: 1081

Re: CumulusMX - Trojan/Malware In DLL

Toxic17 wrote:
steve wrote:Hopefully this thread title won't put off the casual observer from trying Cumulus MX :(
I wonder how many Companies have had their products tainted by a pathetic MS app called Defender.
Any company using a free consumer tool for security deserves to have their products tainted.