Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Search found 55 matches

by david3
Fri 12 Jul 2019 7:06 pm
Forum: Cumulus MX
Topic: How to enable TLS v1.2 or v1.1 for ftps?
Replies: 4
Views: 164

Re: How to enable TLS v1.2 or v1.1 for ftps?

Yes, it was there.

Code: Select all

-rw-r--r--  1 root root  244224 Feb  6 13:04 FluentFTP.dll
by david3
Fri 12 Jul 2019 7:04 pm
Forum: Cumulus MX
Topic: Realtime files not uploading unless ftp logging enabled
Replies: 3
Views: 209

Re: Realtime files not uploading unless ftp logging enabled

I just unzipped the files on top of my existing CumulusMX directory.

I tried later to remove the dll's and the interface directory, and then extracted them from v3050 to make sure there wasn't old stuff left behind that might interfere. It didn't seem to make any difference, though.
by david3
Fri 12 Jul 2019 4:13 pm
Forum: Cumulus MX
Topic: How to enable TLS v1.2 or v1.1 for ftps?
Replies: 4
Views: 164

Re: How to enable TLS v1.2 or v1.1 for ftps?

I had ftp logging enabled while testing. That's where the warning message came from when it tried to connect.

Oh well, it was worth a try.
by david3
Fri 12 Jul 2019 12:45 pm
Forum: Cumulus MX
Topic: Realtime files not uploading unless ftp logging enabled
Replies: 3
Views: 209

Realtime files not uploading unless ftp logging enabled

I've noticed after upgrading to v3050 that the realtime files won't upload unless ftp logging is enabled. If it's disabled, the 5 minute files still upload, but the realtime files (every 10 seconds for me) do not. If I enable the ftp logging, then it starts to upload again. I've also noticed that ev...
by david3
Fri 12 Jul 2019 11:39 am
Forum: Cumulus MX
Topic: How to enable TLS v1.2 or v1.1 for ftps?
Replies: 4
Views: 164

How to enable TLS v1.2 or v1.1 for ftps?

I just upgraded from v3043 to v3050. Thank you for the updates. I saw in the release notes that support for TLS v1.1 and TLS v1.2 has been added for ftps. When I restrict my ftps server (vsftpd) to TLS v1.2 or TLS v1.1, CumulusMX refuses to connect. It only works if I allow TLS v1.0 (like before). I...
by david3
Thu 26 Jul 2018 12:38 pm
Forum: Cumulus MX
Topic: The handshake failed due to un unexpected packet format
Replies: 38
Views: 11389

Re: The handshake failed due to un unexpected packet format

Yes... To be clear, it's only the ftp server that requires TLS 1.0 (for CumulusMX ftps uploading).
by david3
Wed 25 Jul 2018 5:34 pm
Forum: Cumulus MX
Topic: The handshake failed due to un unexpected packet format
Replies: 38
Views: 11389

Re: The handshake failed due to un unexpected packet format

I just ran into this same issue after my ftp server was upgraded from vsftpd v2.2.2 to vsftpd v3.0.2 (which came with the upgrade from CentOS 6 to CentOS 7). with v2.2.2 my vsftpd.conf had ssl_tlsv1_2=YES with v3.0.2 I kept getting the error in ftplog.txt There is stale data on the socket, maybe our...
by david3
Tue 17 Jul 2018 10:45 am
Forum: Cumulus MX
Topic: importcumulusfile.php Failed to bind the SQL parameters!
Replies: 2
Views: 476

Re: importcumulusfile.php Failed to bind the SQL parameters!

Thanks! Version 2.8 worked fine.

I found I was using v3.0 before, and also tried v3.1, but got the same error. v2.8 is good, though.
by david3
Tue 17 Jul 2018 9:00 am
Forum: Cumulus MX
Topic: importcumulusfile.php Failed to bind the SQL parameters!
Replies: 2
Views: 476

importcumulusfile.php Failed to bind the SQL parameters!

I'm trying to import my dayfile.txt into a mysql database. I've got the latest version of importcumulusfile.php from the wiki and set the various paramters. It imports dayfile.txt, connects to the database, and creates the table ok, but when it goes to insert the data it gets an error. Here's the ou...
by david3
Sat 30 Jun 2018 6:46 pm
Forum: Cumulus MX
Topic: My upgrade from Cumulus 1.9.4 (win) to Cumulus MX (rpi)
Replies: 1
Views: 720

My upgrade from Cumulus 1.9.4 (win) to Cumulus MX (rpi)

I recently upgraded from Cumulus 1.9.4 (build 1099) running on Windows to Cumulus MX (v3.0.0 build 3043) running on a Raspberry Pi 3 Model B+ (Raspbian Stretch). I ran into a few hiccups I thought I'd note in case it helps somebody else doing this upgrade later. I imagine these would not be issues f...
by david3
Fri 29 Jun 2018 9:21 am
Forum: Cumulus MX
Topic: Server Generated Graphs for MX
Replies: 209
Views: 101816

Re: Server Generated Graphs for MX

I just upgraded from Cumulus 1 running on Windows to Cumulus MX running on a Raspberry Pi Model 3B+. I've got the graphs working with jpgraphs, but I notice the last Daily Rainfall graph (from the old graphs) is missing; the one that charts the last month's rainfall, day by day. I'm guessing the dat...
by david3
Thu 28 Apr 2016 3:33 pm
Forum: Davis VP/VP2/Vue
Topic: Catching up with missing data with the VantageVue logger
Replies: 4
Views: 1071

Re: Catching up with missing data with the VantageVue logger

Yes, I must have connected the cables in a different order after replacing the power supply so I had to change the com port setting. Thanks for the info, and for looking at the logs. I'll try to remember to change the com port setting in the cumulus.ini file in the future. I copied the backup data a...
by david3
Thu 28 Apr 2016 12:27 pm
Forum: Davis VP/VP2/Vue
Topic: Catching up with missing data with the VantageVue logger
Replies: 4
Views: 1071

Catching up with missing data with the VantageVue logger

I have a Davis VantageVue running with Cumulus, and the logger interval is set to 10 minutes on both the VantageVue and in Cumulus. Today my PC's power supply stopped working, so it was down for about 5 hours. When I started Cumulus up again, I expected it would read the archive data from the logger...
by david3
Tue 02 Dec 2014 12:20 pm
Forum: Saratoga Templates
Topic: wxuvforecast.php discrepancy with home page
Replies: 0
Views: 812

wxuvforecast.php discrepancy with home page

I noticed that the UV strength (Low, Medium, High, Very High, Extreme) was sometimes different on the home page vs. the wxuvforecast.php page. For example, the main page would say: UV Index Forecast UV Index Forecast 12/02/2014 12/03/2014 7.6 High 7.2 High But the wxuvforecast page would say: Tue We...