Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.3.0 build 3063 - 10 January 2020.
    Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

    See the Wiki for downloading either version.

    Search found 216 matches

    by Adrian Hudson
    Sun 25 Aug 2019 4:29 pm
    Forum: Cumulus MX
    Topic: Cumulus log file format on Raspberry Pi
    Replies: 2
    Views: 219

    Cumulus log file format on Raspberry Pi

    I run Cumulus MX on a RPI where it creates text files in the unix style (line endings just LF). I have a Windows PC which wakes up periodically to run WXSIM. It copies the latest log file from the RPI and uses it in making a weather forecast. This part runs fine (wxsimate is happy with the unix styl...
    by Adrian Hudson
    Thu 15 Dec 2016 9:48 am
    Forum: Cumulus 1 (discontinued)
    Topic: Cumulus Support for Weathercloud
    Replies: 59
    Views: 17078

    Re: Cumulus Support for Weathercloud

    Hello all. I'm the author of this utility. The program is written in a language called Autoit (https://www.autoitscript.com) which is very good but has the unfortunate problem that many antivirus programs flag programs written in it as viruses  (https://www.autoitscript.com/forum/topic/34658-are-my-...
    by Adrian Hudson
    Mon 24 Oct 2016 3:18 pm
    Forum: Cumulus MX
    Topic: Migration underway
    Replies: 14
    Views: 1662

    Re: Migration underway

    Hi Dave, Could you explain and expand on what you mean by this please: "concluded that porting the Cumulus 1 arrangements over to Cumulus-MX was not the way to go" I have had a couple of attempts to mode to the Pi over the years - I don't run the default web site which is probably half my problem bu...
    by Adrian Hudson
    Sat 22 Oct 2016 9:12 pm
    Forum: Cumulus MX
    Topic: TempMult2 in cumulus.ini
    Replies: 2
    Views: 541

    Re: TempMult2 in cumulus.ini

    ahhhhhhhh! That explains a lot! I couldn't figure out what I was doing wrong!! Thanks Steve, I look forward to the next build :-)
    by Adrian Hudson
    Sat 22 Oct 2016 7:57 pm
    Forum: Cumulus MX
    Topic: TempMult2 in cumulus.ini
    Replies: 2
    Views: 541

    TempMult2 in cumulus.ini

    Steve, Some time ago, at my suggestion, you added the TempMult2 paramer in the Offsets section of cumulus.ini to allow correction of non-linear errors in the temperature sensor. I used this facility until my sensor failed and on replacing it I found the new one to be so accurate that I no longer rea...
    by Adrian Hudson
    Sun 18 Sep 2016 6:09 pm
    Forum: Saratoga Templates
    Topic: Saratoga templates on Raspberry PI
    Replies: 5
    Views: 2417

    Re: Saratoga templates on Raspberry PI

    @jlmr731

    Many thanks for your suggestion. I am embarrassed to say I had the whole site in a subfolder of \www\html and had forgotten! Quoting the whole path indeed fixed it! Thanks.
    by Adrian Hudson
    Sun 18 Sep 2016 3:03 pm
    Forum: Saratoga Templates
    Topic: Saratoga templates on Raspberry PI
    Replies: 5
    Views: 2417

    Re: Saratoga templates on Raspberry PI

    Thanks Steve. The problem doesn't seem to be anything to do with this number in the url. I just requested the realtime.txt manually from a web browser and the pi responded with the file, whether or not I appended a question mark and a number. So, I'm stumped. I have tried $SITE['realtimefile'] = './...
    by Adrian Hudson
    Sun 18 Sep 2016 1:51 pm
    Forum: Saratoga Templates
    Topic: Saratoga templates on Raspberry PI
    Replies: 5
    Views: 2417

    Saratoga templates on Raspberry PI

    Hi, I reckon this is a simple problem but I am darned if I know whats going on. I am porting my website from Windows to RPI and its going okay - ish. One problem I don't seem to be able to get over is the templates not finding my realtime.txt file. Here is a line from the Apache log: ... 14:26:49 +0...
    by Adrian Hudson
    Sun 17 Apr 2016 9:14 pm
    Forum: Homebuilt
    Topic: New Davis TH sensor
    Replies: 13
    Views: 4828

    Re: New Davis TH sensor

    Hi Mark,

    I can't find anything about this. Have you got any links you can post please?

    Thanks
    by Adrian Hudson
    Mon 04 Jan 2016 10:50 am
    Forum: Cumulus MX
    Topic: Rain error last day of year (9am rollover)
    Replies: 4
    Views: 994

    Re: Rain error last day of year (9am rollover)

    I can imagine 9am end of day processing is tricky enough as it is so it might be best left well alone! I'll set my weatherlink update to be after end of day.
    by Adrian Hudson
    Sun 03 Jan 2016 5:56 pm
    Forum: Cumulus MX
    Topic: Rain error last day of year (9am rollover)
    Replies: 4
    Views: 994

    Re: Rain error last day of year (9am rollover)

    My initial statement was only partially true :-) Whereas I was indeed, asleep at 08:20 - and therefore not fiddling with the PC, a script woke up at 08:25 and ended the program (nicely) for a couple of minutes so that WeatherLink could download from the VP2. It does this every 5 days. The problem ap...
    by Adrian Hudson
    Sat 02 Jan 2016 4:09 pm
    Forum: Cumulus MX
    Topic: Rain error last day of year (9am rollover)
    Replies: 4
    Views: 994

    Rain error last day of year (9am rollover)

    Hi Steve, I can't see this mentioned in other posts... Just before the yearly rollover - at 08:20 was 4.0 mm and then at 08:30 went to zero. This meant the day total was zero and this was reflected in the dayfile. Nothing was untoward with the machine I was enjoying a lay-in so it wasn't me fiddling...
    by Adrian Hudson
    Sun 24 May 2015 9:51 pm
    Forum: Cumulus MX
    Topic: MySQL - Custom uploads
    Replies: 11
    Views: 1240

    Re: MySQL - Custom uploads

    PS: Thanks very much for this functionality - I think it is a great enhancement to Cumulus :clap: :clap: :clap: I would like to second that!! ... Now that web tags have this new use, I'll have to look at getting them all to work during logger download. The same thing is going to apply to the custom...
    by Adrian Hudson
    Fri 22 May 2015 9:37 am
    Forum: Cumulus MX
    Topic: Not downloading all of Davis archive
    Replies: 11
    Views: 1544

    Re: Not downloading all of Davis archive

    Hi Steve, No, sorry, after I deinstalled DrivePool (and decided to use Win 8.1 Storage Spaces - very opaque and fairly inflexible -but does just work) I didn't bother to re-test as it had been a bit of a palaver to deinstall. However, as a belated test, I have just restored back two days and let it ...
    by Adrian Hudson
    Sun 17 May 2015 2:03 pm
    Forum: Cumulus MX
    Topic: Not downloading all of Davis archive
    Replies: 11
    Views: 1544

    Re: Not downloading all of Davis archive

    That's what I meant. When I put a new version of Drivepool on the machine, it didn't preserve the volume serial number and so the software thought I had moved it to a new machine. I have to say, that using the volume serial number isn't a good idea (been there, done that myself) but that's not the p...