Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.2 build 3052 - 13 September 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Search found 5681 matches

by mcrossley
Sun 20 Oct 2019 1:24 pm
Forum: SteelSeries Gauges
Topic: V 2.7.3 Upgrade Issues
Replies: 12
Views: 112

Re: V 2.7.3 Upgrade Issues

I don't see any issues with the scaling, at the moment the temperature scale is -5 to 35 which is what you have defined as the min max in the script. Your dew point is frequently going below -5 or even -10. When that happens the gauge has to re-scale below your defined min of -5. Then the "nice scal...
by mcrossley
Sat 19 Oct 2019 10:29 pm
Forum: SteelSeries Gauges
Topic: changing tempScaleDefMaxC causes erratic behaviour
Replies: 6
Views: 1499

Re: changing tempScaleDefMaxC causes erratic behaviour

you need to add the niceScale = false in your second block of code.
by mcrossley
Fri 18 Oct 2019 11:51 am
Forum: Cumulus 1 (discontinued)
Topic: Rare problem with "log" file of the current month
Replies: 18
Views: 192

Re: Rare problem with "log" file of the current month

As this discussion is irrelevant to C1 I have created a new thread on the CMX forum. Please direct input on locales there.
by mcrossley
Fri 18 Oct 2019 11:50 am
Forum: Cumulus MX
Topic: Locale Issues with Month Name
Replies: 1
Views: 41

Locale Issues with Month Name

The Mono version 5 release has thrown up an issue with some locales and the short month names. They have changed the short month name (in English for example) from "Jan" to "Jan." CMX uses the short month name to name the log files, and this change means that it can no longer find any of the existin...
by mcrossley
Fri 18 Oct 2019 11:12 am
Forum: Cumulus MX
Topic: Problem on send data external services
Replies: 11
Views: 211

Re: Problem on send data external services

Can you also send your Cumulus.ini file please?
NOTE: It contains usernames and passwords - please remove them before posting the file.
by mcrossley
Fri 18 Oct 2019 10:52 am
Forum: Cumulus MX
Topic: Beta testers wanted for new release.
Replies: 16
Views: 463

Re: Beta testers wanted for new release.

The beta is drawing to a close now, but I'll email you the details...
You may want to remove your email address from the above post now?
by mcrossley
Thu 17 Oct 2019 5:59 pm
Forum: Cumulus MX
Topic: Problem on send data external services
Replies: 11
Views: 211

Re: Problem on send data external services

Just to be clear, when it stopped working on 4th October, had you installed a new version of MX?

Did anything else change, like an apt upgrade of mono?
by mcrossley
Thu 17 Oct 2019 5:26 pm
Forum: Cumulus MX
Topic: Problem on send data external services
Replies: 11
Views: 211

Re: Problem on send data external services

Hmm it isn't logging anything about web uploads. It does seem to have some issues talking to the station from time to time.

I'm not very familiar with the WMR100 code, I'll have to take a look at what it is doing...
by mcrossley
Thu 17 Oct 2019 2:39 pm
Forum: Cumulus 1 (discontinued)
Topic: Rare problem with "log" file of the current month
Replies: 18
Views: 192

Re: Rare problem with "log" file of the current month

I disagree, but without the original poster responding with his Windows date settings then we will never be certain what the cause of this issue is. All I can say is that every time this has occurred in the past with C1 it has been due to the Windows date format or locale being changed. Lots of coun...
by mcrossley
Thu 17 Oct 2019 11:06 am
Forum: Cumulus 1 (discontinued)
Topic: Rare problem with "log" file of the current month
Replies: 18
Views: 192

Re: Rare problem with "log" file of the current month

@mcrossley: You may consider creating a workaround in Cumulus itself at the point where the filename is created: check for the point and if so, remove it. As a result, the filename will always be correct. You may also simply construct the filename yourself from the month number in the date. Not so ...
by mcrossley
Wed 16 Oct 2019 10:36 pm
Forum: Cumulus MX
Topic: Help..................
Replies: 19
Views: 313

Re: Help..................

Two releases in September and a beta underway is "death throes"? OK, whatever.

From that screen shot it looks like your remote folder is actually "/public_html/cumulus" not the "cumulus" you have entered.
by mcrossley
Wed 16 Oct 2019 10:31 pm
Forum: Cumulus MX
Topic: Docker Friendly
Replies: 6
Views: 114

Re: Docker Friendly

Yep, I get where you're coming from. So if you stored the ini file (and the data and backup folders) outside the image and had symbolic links to the locations from inside your docker image then when you tear down and stand up your container the symbolic links (being part of the image) should allow ...
by mcrossley
Wed 16 Oct 2019 10:24 pm
Forum: Cumulus MX
Topic: Problem on send data external services
Replies: 11
Views: 211

Re: Problem on send data external services

It doesn't have debug logging enabled.
by mcrossley
Wed 16 Oct 2019 8:03 am
Forum: Cumulus MX
Topic: Help..................
Replies: 19
Views: 313

Re: Help..................

It is saying the cumulus folder does not exist on your web server.
Login to the FTP server with an FTP client do nothing else and take screen shot, we need to see where the FTP root folder is for your user.

Plus you haven't given us a link to your website yet. Without information we are guessing.
by mcrossley
Tue 15 Oct 2019 5:57 pm
Forum: Cumulus MX
Topic: Problem on send data external services
Replies: 11
Views: 211

Re: Problem on send data external services

Make sure you have switched on debug logging, leave it running for a couple of upload intervals, then post the zipped up MXdiags folder.