Welcome to the Cumulus Support forum.

Latest Cumulus MX release v3.0.0 build 3050 - 1 May 2019.
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014

See the Wiki for downloading either version.

Search found 957 matches

by saratogaWX
Tue 21 May 2019 1:01 am
Forum: Saratoga Templates
Topic: Summary / Temperature image display problem on my site
Replies: 2
Views: 27

Re: Summary / Temperature image display problem on my site

Your DarkSky forecast request is failing <!-- DS-forecast.php (ML) Version 1.09 - 23-Jan-2019 on PHP 5.6.40 --> <!-- temps in C --> <!-- DS URL: https://api.darksky.net/forecast/77d13a3e2b7bd06ce1da8dcf8f0e1aa9/45.6015332,9.1220693?exclude=minutely&lang=it&units=si --> <!-- autoSetTemplate using nar...
by saratogaWX
Tue 30 Apr 2019 10:13 pm
Forum: Saratoga Templates
Topic: Updated advforecast2.php (JSON) V5.11 handles NWS API change
Replies: 3
Views: 407

Re: Updated advforecast2.php (JSON) V5.11 handles NWS API change

Thanks for the kind words!! It has been a challenge, especially with the NOAA / NWS sites switching awkwardly to HTTPS, and the long-delayed conversion of weather.gov to a new format. :bash: :evil: Sometimes, I hear the hole in the ground whispering softly to me... but, I'm not quite dead yet. :ugeek:
by saratogaWX
Tue 30 Apr 2019 6:39 pm
Forum: Saratoga Templates
Topic: Updated advforecast2.php (JSON) V5.11 handles NWS API change
Replies: 3
Views: 407

Updated advforecast2.php (JSON) V5.11 handles NWS API change

With the announcement of the NWS on 29-Apr-2019 that the api.weather.gov was deprecating the forecast queries for points/ and removing the current 302 redirect to a gridpoint forecast, the underlying method of using the API had to change in the script. Now, the specified point's meta-data is fetched...
by saratogaWX
Wed 17 Apr 2019 6:05 pm
Forum: Saratoga Templates
Topic: ec-radar.php V2.04 released
Replies: 0
Views: 239

ec-radar.php V2.04 released

I was noticing a lot of error_log entries due to queries for non-existent radar sites with ec-radar.php, so I've updated the script to include the 'allowed' list of Environment Canada siteids that the script can use. It returns a 'invalid site' message if the site selected is not in the known list. ...
by saratogaWX
Thu 11 Apr 2019 10:07 pm
Forum: Weather34 Home Weather Station
Topic: Weather34 Home Weather Station Template
Replies: 144
Views: 14286

Re: Weather34 Home Weather Station Template

Ahh, yes... I've been sorting through the main.dark.css to fix some validation errata, and haven't had time to port those changes to the main.light.css quite yet. Thanks for the heads-up.
by saratogaWX
Tue 26 Mar 2019 10:26 pm
Forum: Web site - General
Topic: Using the new WU API
Replies: 12
Views: 1189

Re: Using the new WU API

Here's a working version of your script with a few tweaks. Just insert your API key at the top. <?php $apiKey = '--api-key-here--'; $station = 'IONTARIO226'; /* stdClass Object ( [observations] => Array ( [0] => stdClass Object ( [stationID] => IONTARIO226 [obsTimeUtc] => 2019-03-26T22:14:58Z [obsTi...
by saratogaWX
Mon 11 Mar 2019 2:36 pm
Forum: Saratoga Templates
Topic: Weather Trends (wxtrends.php)
Replies: 16
Views: 541

Re: Weather Trends (wxtrends.php)

Take a look at http://wxstation.us/weather/wxstatus.php -- the CUtags.php file has stale data and is not being uploaded. It has the data for 'yesterday' and all the data not included in realtime.txt for display.

Fix the CUtags.php processing/upload and your site will return to normal displays.
by saratogaWX
Sat 09 Mar 2019 8:56 pm
Forum: Saratoga Templates
Topic: wxadvisory.php Not working
Replies: 2
Views: 246

Re: wxadvisory.php Not working

The new-format URLs for meteoalarm.eu should work fine with get-meteoalarm-warning-inc.php V1.10 -- they do on my site.
by saratogaWX
Fri 22 Feb 2019 7:05 pm
Forum: Cumulus MX
Topic: Cumulus MX not downloading data from datalogger through VVP
Replies: 2
Views: 180

Re: Cumulus MX not downloading data from datalogger through VVP

Are you using VSPE (or equivalent) for doing the serial-port null modem connections? How are your port pairs set up? On my setup, I have VirtualVP reading COM2 for the Davis VP1 serial connection. VSPE establishes the following null-modem port pairs: COM5:COM15 COM6:COM16 COM7:COM17 COM8:COM19 Then ...
by saratogaWX
Fri 22 Feb 2019 6:59 pm
Forum: Saratoga Templates
Topic: Wrong data on my website
Replies: 32
Views: 1054

Re: Wrong data on my website

Also, you have Active FTP set -- that should likely be turned off so you use Passive FTP as the upload mechanism.

It's also surprising that none of the extra files (CUtags.php and gauges.htm) appear in the FTP log.. it looks like it is not sending them to the site.
by saratogaWX
Thu 21 Feb 2019 6:11 pm
Forum: Weather34 Home Weather Station
Topic: Weather34 Home Weather Station Template
Replies: 144
Views: 14286

Re: Weather34 Home Weather Station Template

Now it looks like you have the realtime set to 'demodata/realtime.txt' instead of 'realtime.txt'.

Use easyweathersetup.php to correct that.
by saratogaWX
Thu 21 Feb 2019 1:25 am
Forum: Weather34 Home Weather Station
Topic: Weather34 Home Weather Station Template
Replies: 144
Views: 14286

Re: Weather34 Home Weather Station Template

Sure.. I think it's a simple matter of using easyweathersetup.php to correct the livedata source:

Currently you have it as /realtime.txt
Set it to just realtime.txt and it should work.

The / means it is looking for the realtime.txt file in the root of the filesystem (and it's not there :) )
by saratogaWX
Thu 21 Feb 2019 1:21 am
Forum: Saratoga Templates
Topic: Wrong data on my website
Replies: 32
Views: 1054

Re: Wrong data on my website

Hopefully I have not missed something obvious, but It looks like this is using CumulusMX b3043 (from realtime.txt) https://vejr.perlaustsen.dk/realtime.txt However the template footer says Cumulus (1.9.0 - b958) https://vejr.perlaustsen.dk/index.php Paul, I think that's because he has uploaded a co...
by saratogaWX
Tue 19 Feb 2019 7:27 pm
Forum: Saratoga Templates
Topic: Wrong data on my website
Replies: 32
Views: 1054

Re: Wrong data on my website

Thanks for chiming in, Mark! I think the issue now is a pre-processed CUtags.txt with no <#...> variables in it. Copying the CUtags.txt from the CU-plugin.zip should fix perl's issue.
by saratogaWX
Tue 19 Feb 2019 7:01 pm
Forum: Saratoga Templates
Topic: Wrong data on my website
Replies: 32
Views: 1054

Re: Wrong data on my website

You might try changing the template files to /home/CumulusMX/web directory .. it may be that CumulusMX processes the CUtags.txt in the /home/CumulusMX directory IN PLACE and so one update will clobber the template file.