Welcome to the Cumulus Support forum.

Latest Cumulus MX release 3.6.6 (build 3082) - 1 June 2020 (please see important announcement regarding releases since 3.5.0)
Legacy Cumulus 1 release v1.9.4 (build 1099) - 28 November 2014 (a patch is available for 1.9.4 build 1099 that extends the date range of the NOAA report and Snow Index drop-down menus to 2030)

See the Wiki to download the software or click on the Downloads link in the Forum Banner.

Search found 88 matches

by Herbaldew
Wed 18 Mar 2020 6:19 pm
Forum: Saratoga Templates
Topic: Temperature only displaying to one decimal point
Replies: 7
Views: 825

Re: Temperature only displaying to one decimal point

Try clearing your cache - it is working properly for me now.
by Herbaldew
Thu 28 Nov 2019 2:18 pm
Forum: Cumulus MX Current (releases since b3043)
Topic: Standing at the precipice...
Replies: 6
Views: 345

Re: Standing at the precipice...

Before you spend any $$$ on it (like buying a Win 7 license) - I would recommend researching Raspberry Pi if you haven't already. Cheap, tiny, silent and has been rock solid for me.
by Herbaldew
Sun 01 Sep 2019 7:21 pm
Forum: Cumulus MX Current (releases since b3043)
Topic: Missing data on dashboard
Replies: 40
Views: 1474

Re: Missing data on dashboard

For another purpose (testing some hardware) I installed a brand new fresh download of Raspbian Buster from the official site (dated last month), installed mono-complete, and it installed version 5.18 for me? Raspbian Buster w/Desktop - 5.18 installed here as well. I used to force a newer version pr...
by Herbaldew
Thu 22 Aug 2019 3:02 am
Forum: Cumulus MX Current (releases since b3043)
Topic: CumulusMX dashboard password protect
Replies: 6
Views: 374

Re: CumulusMX dashboard password protect

You could edit the html to remove the settings related links. That doesn't block access to them, but you would have to know the address to manually access them rather than just clicking a link. I guess along those lines you could also delete the settings pages and just upload them when you need to u...
by Herbaldew
Wed 05 Sep 2018 4:53 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Add Extra Temp Value to Interface Page
Replies: 10
Views: 1996

Re: Add Extra Temp Value to Interface Page

I initially had no luck getting this to do anything and moved on to trying to truncate numbers in my iframe method. After figuring out how to truncate my numbers using said iframe method of getting extra temp 1 to display I came back to this to try to figure out how to do it "right". I immediately n...
by Herbaldew
Tue 04 Sep 2018 1:47 pm
Forum: Web site - General
Topic: Truncate Webtag Value
Replies: 3
Views: 1430

Re: Truncate Webtag Value

Thanks. After a good bit of frustration, I did it with JavaScript.

I was trying to work this out on Internet Explorer as it is what I use for my CMX interface. Turns out that Math.trunc doesn't work on IE :( Using Math.floor instead produced the desired result :)
by Herbaldew
Sun 02 Sep 2018 4:32 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Add Extra Temp Value to Interface Page
Replies: 10
Views: 1996

Re: Add Extra Temp Value to Interface Page

Code: Select all

{"data":[["Sensor 1","81.0","°F"],["Sensor 2","0.0","°F"],["Sensor 3","0.0","°F"],["Sensor 4","0.0","°F"],["Sensor 5","0.0","°F"],["Sensor 6","0.0","°F"],["Sensor 7","0.0","°F"],["Sensor 8","0.0","°F"],["Sensor 9","0.0","°F"],["Sensor 10","0.0","°F"]]}
by Herbaldew
Sun 02 Sep 2018 3:44 pm
Forum: Web site - General
Topic: Truncate Webtag Value
Replies: 3
Views: 1430

Truncate Webtag Value

When using the webtag for extra temp 1, the value returned has a decimal and a zero, and it displays as eg "81.0". How can I make it drop the decimal and tenths position, and make it display as eg "81"? In the case of Davis anyway, the extra temp sensors only return full numbers, no tenths thus maki...
by Herbaldew
Sun 02 Sep 2018 3:37 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Add Extra Temp Value to Interface Page
Replies: 10
Views: 1996

Re: Add Extra Temp Value to Interface Page

Thanks for the information. I didn't figure out how to extract just the value of extra sensor 1 from that JSON. I did figure out a way to put the value under my temp guage on my gauges page. It's ugly behind the scenes but looks nearly the same when viewing my gauge page. I already have Apache runni...
by Herbaldew
Fri 31 Aug 2018 7:57 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Add Extra Temp Value to Interface Page
Replies: 10
Views: 1996

Add Extra Temp Value to Interface Page

I just added an extra temp sensor to my VP2 and have been trying to add it's value in a couple places on my interface pages. I see the temp listed as Sensor 1 under the Extra sensors link. I have not succeeded. After reading many posts, I now wonder, is this even possible with a reasonable amount of...
by Herbaldew
Fri 06 Jul 2018 12:36 am
Forum: Homebuilt
Topic: WiFiLogger for Davis stations
Replies: 35
Views: 16394

Re: WiFiLogger for Davis stations

Its been a week since you last posted - any update on how things are going? Now been 2 days since the new firmware with the TCP Port Auto pause setting and CumulusMX at 15 sec disconnect and all seems well. I am curious about this. I have a MeteoBridge uploading to WU & CWOP and an rPi running Cumul...
by Herbaldew
Sat 30 Jun 2018 8:35 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Gauges Page Broken with 2018-06-27-raspbian-stretch
Replies: 3
Views: 820

Re: Gauges Page Broken with 2018-06-27-raspbian-stretch

Heat index here is 105 f - good day to play with this thing :) Turns out that IceWeasel does NOT work properly for the gauges page with the last version of Raspbian either. I had never fooled with another browser other than the included Chromium so didn't know anything about them. IceWeasel if basic...
by Herbaldew
Sat 30 Jun 2018 3:27 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Gauges Page Broken with 2018-06-27-raspbian-stretch
Replies: 3
Views: 820

Re: Gauges Page Broken with 2018-06-27-raspbian-stretch

Thanks, I had read that as it was unfolding but it didn't cross my mind for my problem. My symptoms are slightly different in that my gauges page won't load to start with. That was fixed in regular Chrome, but maybe whatever the problem was made it to the rPi version without getting fixed and is gen...
by Herbaldew
Sat 30 Jun 2018 2:23 pm
Forum: CumulusMX Beta (releases up to b3043)
Topic: Gauges Page Broken with 2018-06-27-raspbian-stretch
Replies: 3
Views: 820

Gauges Page Broken with 2018-06-27-raspbian-stretch

No idea where to look for what is causing this... No changes have been made from my settings with the last release. But now, my "index" page works fine including the wind gauges. My "gauges" page will load but the gauges will not connect (this is using the Chromium browser on the rPi). Eventually I ...
by Herbaldew
Sun 01 Apr 2018 9:43 pm
Forum: Cumulus MX Current (releases since b3043)
Topic: Server Generated Graphs for MX
Replies: 218
Views: 125281

Re: Server Generated Graphs for MX

Can one make the popup graphs work on the CMX interface (running on rPi)? I now have pop up graphs on my interface :D First iteration...I did a full web site setup on my rPi with Apache, PHP, JpGraph and Mark's files. I then went through the trouble of converting my customized interface gauges page...